summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/ardour/ardour.SlackBuild10
-rw-r--r--audio/ardour/ardour.info6
-rw-r--r--audio/ardour/libxml2-2.12-fix.patch53
-rw-r--r--audio/ardour/vendor_qm-dsp.patch37
-rw-r--r--audio/audacity/audacity.SlackBuild8
-rw-r--r--audio/audacity/audacity.info10
-rw-r--r--audio/openvino-plugins-ai-audacity/README16
-rw-r--r--audio/openvino-plugins-ai-audacity/openvino-plugins-ai-audacity.SlackBuild158
-rw-r--r--audio/openvino-plugins-ai-audacity/openvino-plugins-ai-audacity.info20
-rw-r--r--audio/openvino-plugins-ai-audacity/slack-desc19
-rw-r--r--audio/rack/rack.SlackBuild2
-rw-r--r--audio/rack/rack.info6
-rw-r--r--audio/yabridge/yabridge.info2
13 files changed, 234 insertions, 113 deletions
diff --git a/audio/ardour/ardour.SlackBuild b/audio/ardour/ardour.SlackBuild
index 63f72ba036..8dfad24c8d 100644
--- a/audio/ardour/ardour.SlackBuild
+++ b/audio/ardour/ardour.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for ardour
# Copyright 2008-2016 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2018-2023 Matteo Bernardini, Pisa, Italy
+# Copyright 2018-2024 Matteo Bernardini, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ardour
-VERSION=${VERSION:-8.1.0}
+VERSION=${VERSION:-8.6.0}
MAJVER=$(echo $VERSION | cut -d. -f1)
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,9 +61,6 @@ else
TARGET="$ARCH"
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$TARGET-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -88,8 +85,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
-# Thanks to fourtysixandtwo for pointing at this upstream pull request!
-patch -p1 < $CWD/libxml2-2.12-fix.patch
+sed -i "s|env\ python|env\ python3|" waf wscript
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/audio/ardour/ardour.info b/audio/ardour/ardour.info
index c68b2e5110..5a1196d197 100644
--- a/audio/ardour/ardour.info
+++ b/audio/ardour/ardour.info
@@ -1,8 +1,8 @@
PRGNAM="ardour"
-VERSION="8.1.0"
+VERSION="8.6.0"
HOMEPAGE="http://ardour.org"
-DOWNLOAD="https://ponce.cc/slackware/sources/repo/Ardour-8.1.0.tar.bz2"
-MD5SUM="278d59f3343057124989acbbf67d7f15"
+DOWNLOAD="https://ponce.cc/slackware/sources/repo/Ardour-8.6.0.tar.bz2"
+MD5SUM="b3f176e79f14988c7b42479214c15184"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="aubio jack liblo liblrdf rubberband suil cwiid lilv vst3sdk"
diff --git a/audio/ardour/libxml2-2.12-fix.patch b/audio/ardour/libxml2-2.12-fix.patch
deleted file mode 100644
index 00ebd0f4e2..0000000000
--- a/audio/ardour/libxml2-2.12-fix.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From e995daa37529715214c6c4a2587e4134aaaba02f Mon Sep 17 00:00:00 2001
-From: Nils Philippsen <nils@tiptoe.de>
-Date: Fri, 17 Nov 2023 23:26:06 +0100
-Subject: [PATCH] Fix failure to build with libxml2 version 2.12
-
-This declared some xmlError pointers const, which probably was always
-assumed, but not made explicit.
-
-Signed-off-by: Nils Philippsen <nils@tiptoe.de>
----
- gtk2_ardour/ardour_ui.cc | 8 ++++++--
- libs/pbd/xml++.cc | 2 +-
- 2 files changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/gtk2_ardour/ardour_ui.cc b/gtk2_ardour/ardour_ui.cc
-index 54ed79ea83d..77ddbbe99ca 100644
---- a/gtk2_ardour/ardour_ui.cc
-+++ b/gtk2_ardour/ardour_ui.cc
-@@ -255,7 +255,7 @@ libxml_generic_error_func (void* /* parsing_context*/,
-
- static void
- libxml_structured_error_func (void* /* parsing_context*/,
-- xmlErrorPtr err)
-+ const xmlError *err)
- {
- string msg;
-
-@@ -403,7 +403,11 @@ ARDOUR_UI::ARDOUR_UI (int *argcp, char **argvp[], const char* localedir)
- /* stop libxml from spewing to stdout/stderr */
-
- xmlSetGenericErrorFunc (this, libxml_generic_error_func);
-- xmlSetStructuredErrorFunc (this, libxml_structured_error_func);
-+
-+ /* Cast to xmlStructuredErrorFunc to cope with different constness in different
-+ * versions of libxml2. */
-+
-+ xmlSetStructuredErrorFunc (this, (xmlStructuredErrorFunc)libxml_structured_error_func);
-
- /* Set this up early */
-
-diff --git a/libs/pbd/xml++.cc b/libs/pbd/xml++.cc
-index 5c57ad8395d..1f5a85772f6 100644
---- a/libs/pbd/xml++.cc
-+++ b/libs/pbd/xml++.cc
-@@ -170,7 +170,7 @@ XMLTree::write() const
- result = xmlSaveFormatFileEnc(_filename.c_str(), doc, "UTF-8", 1);
- #ifndef NDEBUG
- if (result == -1) {
-- xmlErrorPtr xerr = xmlGetLastError ();
-+ const xmlError *xerr = xmlGetLastError ();
- if (!xerr) {
- std::cerr << "unknown XML error during xmlSaveFormatFileEnc()." << std::endl;
- } else {
diff --git a/audio/ardour/vendor_qm-dsp.patch b/audio/ardour/vendor_qm-dsp.patch
deleted file mode 100644
index f8265fd6e4..0000000000
--- a/audio/ardour/vendor_qm-dsp.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git i/libs/qm-dsp/wscript w/libs/qm-dsp/wscript
-index 775098e06b..13f6b9410a 100644
---- i/libs/qm-dsp/wscript
-+++ w/libs/qm-dsp/wscript
-@@ -23,17 +23,10 @@ def options(opt):
- autowaf.set_options(opt)
-
- def configure(conf):
-- if conf.is_defined('USE_EXTERNAL_LIBS'):
-- conf.check_cxx(header_name="base/Pitch.h", mandatory=True)
-- conf.check_cxx(lib="qm-dsp", uselib_store="QMDSP", mandatory=True)
-- else:
-- conf.load('compiler_cxx')
-- autowaf.configure(conf)
-+ conf.load('compiler_cxx')
-+ autowaf.configure(conf)
-
- def build(bld):
-- if bld.is_defined('USE_EXTERNAL_LIBS'):
-- return
--
- # Host Library
- obj = bld(features = 'c cxx cxxstlib')
- obj.source = '''
-diff --git i/wscript w/wscript
-index 1c9bb1ff5d..95d377d8a7 100644
---- i/wscript
-+++ w/wscript
-@@ -1041,8 +1041,6 @@ def configure(conf):
-
- if Options.options.use_external_libs:
- conf.define('USE_EXTERNAL_LIBS', 1)
-- conf.env.append_value(
-- 'CXXFLAGS', '-I' + Options.options.qm_dsp_include)
-
- if Options.options.boost_include != '':
- conf.env.append_value('CXXFLAGS', '-I' + Options.options.boost_include)
diff --git a/audio/audacity/audacity.SlackBuild b/audio/audacity/audacity.SlackBuild
index ddaee0e1a0..8d9d32e1dc 100644
--- a/audio/audacity/audacity.SlackBuild
+++ b/audio/audacity/audacity.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for audacity
# Copyright 2006-2010 Chess Griffin <chess@chessgriffin.com>
-# Copyright 2011-2023 Matteo Bernardini <ponce@slackbuilds.org>
+# Copyright 2011-2024 Matteo Bernardini <ponce@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -34,8 +34,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=audacity
-VERSION=${VERSION:-3.4.2}
-MANVER=${MANVER:-3.4.2}
+VERSION=${VERSION:-3.5.1}
+MANVER=${MANVER:-3.5.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -94,6 +94,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+sed -i 's|^#include "allegro.h"|#include "portsmf/allegro.h"|' libraries/lib-note-track/WrapAllegro.h
+
mkdir -p build
cd build
cmake \
diff --git a/audio/audacity/audacity.info b/audio/audacity/audacity.info
index 407e0201a9..e958eb685d 100644
--- a/audio/audacity/audacity.info
+++ b/audio/audacity/audacity.info
@@ -1,10 +1,10 @@
PRGNAM="audacity"
-VERSION="3.4.2"
+VERSION="3.5.1"
HOMEPAGE="https://www.audacityteam.org"
-DOWNLOAD="https://github.com/audacity/audacity/releases/download/Audacity-3.4.2/audacity-sources-3.4.2.tar.gz \
- https://github.com/audacity/audacity/releases/download/Audacity-3.4.2/audacity-manual-3.4.2.zip"
-MD5SUM="f8f96e980b5a880e5be4cd066662b290 \
- fba06b370931a6f0b1a69f5e8a922ab5"
+DOWNLOAD="https://github.com/audacity/audacity/releases/download/Audacity-3.5.1/audacity-sources-3.5.1.tar.gz \
+ https://github.com/audacity/audacity/releases/download/Audacity-3.5.1/audacity-manual-3.5.1.tar.gz"
+MD5SUM="42d866855b2563dc0ec50b9c38476a0d \
+ 237e90933f6367311dcc81a5dd53d075"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libsbsms lilv portaudio portmidi portsmf rapidjson soxr suil wxWidgets"
diff --git a/audio/openvino-plugins-ai-audacity/README b/audio/openvino-plugins-ai-audacity/README
new file mode 100644
index 0000000000..d4111dc4cf
--- /dev/null
+++ b/audio/openvino-plugins-ai-audacity/README
@@ -0,0 +1,16 @@
+A set of AI-enabled effects, generators, and analyzers for Audacity.
+
+These AI features run 100% locally on your PC -- no internet connection
+necessary!
+OpenVINO is used to run AI models on supported accelerators found on
+the user's system such as CPU, GPU, and NPU.
+
+Due to the size of the openvino models, currently only two of the
+effects are provided with this build:
+ -Music Separation -- Separate a mono or stereo track into individual
+ stems -- Drums, Bass, Vocals, & Other Instruments.
+ -Noise Suppression -- Removes background noise from an audio sample.
+
+
+whisper.cpp needs to be build against openvino to pick it up as
+dependency.
diff --git a/audio/openvino-plugins-ai-audacity/openvino-plugins-ai-audacity.SlackBuild b/audio/openvino-plugins-ai-audacity/openvino-plugins-ai-audacity.SlackBuild
new file mode 100644
index 0000000000..84ec8619dd
--- /dev/null
+++ b/audio/openvino-plugins-ai-audacity/openvino-plugins-ai-audacity.SlackBuild
@@ -0,0 +1,158 @@
+#!/bin/bash
+
+# Slackware build script for openvino-plugins-ai-audacity
+
+# Copyright 2024 Johannes Schoepfer, Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=openvino-plugins-ai-audacity
+VERSION=${VERSION:-3.5.1}
+VERSION_SRC="${VERSION}-R2"
+VERSION_AUDACITY=3.5.1
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "arm" ]; then
+ SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
+ LIBDIRSUFFIX=""
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION_SRC
+tar xvf $CWD/$PRGNAM-$VERSION_SRC.tar.gz
+cd $PRGNAM-$VERSION_SRC
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+tar vxf $CWD/audacity-sources-$VERSION_AUDACITY.tar.gz
+
+cat << EOF >> audacity-sources-$VERSION_AUDACITY/modules/CMakeLists.txt
+add_subdirectory(mod-openvino)
+EOF
+mv mod-openvino audacity-sources-$VERSION_AUDACITY/modules/
+
+source /usr/share/openvino/setupvars.sh
+
+cd audacity-sources-$VERSION_AUDACITY
+ sed -i 's|^#include "allegro.h"|#include "portsmf/allegro.h"|' libraries/lib-note-track/WrapAllegro.h
+ mkdir build
+ cd build
+ unshare -n cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS $RPATH $LDPATH" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS $RPATH $LDPATH" \
+ -DAUDACITY_BUILD_LEVEL=2 \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -DHAVE_VISIBILITY=1" \
+ -DCMAKE_CXX_FLAGS_RELEASE:STRING="$SLKCFLAGS -DHAVE_VISIBILITY=1" \
+ -DCMAKE_CXX_STANDARD=11 \
+ -DCMAKE_INSTALL_DOCDIR=/usr/doc/$PRGNAM-$VERSION \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL="on" \
+ -Daudacity_use_twolame="off" \
+ -Daudacity_use_ladspa="off" \
+ -Daudacity_use_soundtouch="off" \
+ -Daudacity_use_vamp="off" \
+ -Daudacity_has_vst3="off" \
+ -Daudacity_use_expat="system" \
+ -Daudacity_use_lame="off" \
+ -Daudacity_use_ffmpeg="off" \
+ -Daudacity_conan_enabled="off" \
+ -Daudacity_has_networking="off" \
+ -Daudacity_has_crashreports="off" \
+ -Daudacity_has_updates_check="off" \
+ -Daudacity_has_sentry_reporting="off" \
+ -Daudacity_obey_system_dependencies="on" \
+ -Daudacity_lib_preference="system" \
+ -Daudacity_use_wxwidgets="system" \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \
+ -DwxWidgets_wxrc_EXECUTABLE=/usr/bin/wxrc \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make mod-openvino
+ make install/strip DESTDIR=$PKG/tmpxxx
+ mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/audacity/modules
+ mv $PKG/tmpxxx/usr/lib$LIBDIRSUFFIX/audacity/modules/mod-openvino.so $PKG/usr/lib$LIBDIRSUFFIX/audacity/modules/mod-openvino.so
+ patchelf --add-rpath "$INTEL_OPENVINO_DIR/runtime/lib/intel64/" $PKG/usr/lib$LIBDIRSUFFIX/audacity/modules/mod-openvino.so
+ rm -rf $PKG/tmpxxx
+ cd ..
+cd ..
+
+# Provide openvino models
+mkdir -p $PKG/usr/lib/openvino-models
+unzip $CWD/deepfilternet2.zip -d $PKG/usr/lib/openvino-models
+unzip $CWD/deepfilternet3.zip -d $PKG/usr/lib/openvino-models
+cp $CWD/htdemucs_v4.bin $PKG/usr/lib/openvino-models
+cp $CWD/htdemucs_v4.xml $PKG/usr/lib/openvino-models
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt README.md doc/feature_doc $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/openvino-plugins-ai-audacity/openvino-plugins-ai-audacity.info b/audio/openvino-plugins-ai-audacity/openvino-plugins-ai-audacity.info
new file mode 100644
index 0000000000..007adbf4e1
--- /dev/null
+++ b/audio/openvino-plugins-ai-audacity/openvino-plugins-ai-audacity.info
@@ -0,0 +1,20 @@
+PRGNAM="openvino-plugins-ai-audacity"
+VERSION="3.5.1"
+HOMEPAGE="https://github.com/intel/openvino-plugins-ai-audacity/"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://github.com/intel/openvino-plugins-ai-audacity/archive/v3.5.1-R2/openvino-plugins-ai-audacity-3.5.1-R2.tar.gz \
+ https://github.com/audacity/audacity/releases/download/Audacity-3.5.1/audacity-sources-3.5.1.tar.gz \
+ https://huggingface.co/Intel/demucs-openvino/resolve/main/htdemucs_v4.xml \
+ https://huggingface.co/Intel/demucs-openvino/resolve/main/htdemucs_v4.bin \
+ https://huggingface.co/Intel/deepfilternet-openvino/resolve/main/deepfilternet2.zip \
+ https://huggingface.co/Intel/deepfilternet-openvino/resolve/main/deepfilternet3.zip"
+MD5SUM_x86_64="3a8159867cf264afc280ab836ef848f9 \
+ 42d866855b2563dc0ec50b9c38476a0d \
+ aa7fcbb6980d83683902ac48c53116be \
+ 1d1fbf4673bd956b3c13879555fa0ad2 \
+ c17382730bdef35c325df210a1ff3d4b \
+ dfaca36bb422a37a299e4f328e1b6843"
+REQUIRES="audacity pytorch whisper.cpp"
+MAINTAINER="Johannes Schoepfer"
+EMAIL="slackbuilds@schoepfer.info"
diff --git a/audio/openvino-plugins-ai-audacity/slack-desc b/audio/openvino-plugins-ai-audacity/slack-desc
new file mode 100644
index 0000000000..a5be7b7654
--- /dev/null
+++ b/audio/openvino-plugins-ai-audacity/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+openvino-plugins-ai-audacity: openvino-plugins-ai-audacity (AI Plugins for Audacity)
+openvino-plugins-ai-audacity:
+openvino-plugins-ai-audacity: A set of AI-enabled effects, generators, and analyzers for Audacity
+openvino-plugins-ai-audacity:
+openvino-plugins-ai-audacity:
+openvino-plugins-ai-audacity:
+openvino-plugins-ai-audacity:
+openvino-plugins-ai-audacity:
+openvino-plugins-ai-audacity:
+openvino-plugins-ai-audacity: https://github.com/intel/openvino-plugins-ai-audacity/
+openvino-plugins-ai-audacity:
diff --git a/audio/rack/rack.SlackBuild b/audio/rack/rack.SlackBuild
index d782b51e9c..438b5e58bf 100644
--- a/audio/rack/rack.SlackBuild
+++ b/audio/rack/rack.SlackBuild
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=rack
SRCNAM=Rack2Free
-VERSION=${VERSION:-2.4.1}
+VERSION=${VERSION:-2.5.1}
SRCDIR=RackFree-$VERSION
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/audio/rack/rack.info b/audio/rack/rack.info
index 89d3f94faa..6ae407805c 100644
--- a/audio/rack/rack.info
+++ b/audio/rack/rack.info
@@ -1,8 +1,8 @@
PRGNAM="rack"
-VERSION="2.4.1"
+VERSION="2.5.1"
HOMEPAGE="https://vcvrack.com"
-DOWNLOAD="https://vcvrack.com/downloads/RackFree-2.4.1-lin-x64.zip"
-MD5SUM="23a13e50f617bc483ca2eb64d48d3b56"
+DOWNLOAD="https://vcvrack.com/downloads/RackFree-2.5.1-lin-x64.zip"
+MD5SUM="ca3a5ec5f1f9a3f948269e731cb73330"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="jack"
diff --git a/audio/yabridge/yabridge.info b/audio/yabridge/yabridge.info
index b5c35ef898..34ee3a893a 100644
--- a/audio/yabridge/yabridge.info
+++ b/audio/yabridge/yabridge.info
@@ -7,7 +7,7 @@ DOWNLOAD="https://github.com/robbert-vdh/yabridge/archive/5.1.0/yabridge-5.1.0.t
MD5SUM="2383d67c9089a4fda8ae311baaa8fe3b \
f9e2185ea8cdfbdc4d99c4a5f5e4d426 \
a58876a05ac16ada09f750a4b8564443"
-DOWNLOAD_x86_64=""
+DOWNLOAD_x86_64="UNSUPPORTED"
MD5SUM_x86_64=""
REQUIRES="%README% wine-staging asio bitsery function2 ghc_filesystem tomlplusplus rust16"
MAINTAINER="Martin BĂ„ngens"