summaryrefslogtreecommitdiffstats
path: root/python/python-sh/python-sh.SlackBuild
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2020-01-26 12:47:45 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-02-01 09:00:35 +0700
commit3f4881e68ba57544f5e45f7bf5004e19b659d709 (patch)
treed8a0fbfe076543fa97488e8c5410ee5f5c4f356a /python/python-sh/python-sh.SlackBuild
parent629343557046a4611d6fcfb55acb973ee1664153 (diff)
downloadslackbuilds-3f4881e68ba57544f5e45f7bf5004e19b659d709.tar.gz
slackbuilds-3f4881e68ba57544f5e45f7bf5004e19b659d709.tar.xz
python/python-sh: Autodetect python3
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'python/python-sh/python-sh.SlackBuild')
-rw-r--r--python/python-sh/python-sh.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/python-sh/python-sh.SlackBuild b/python/python-sh/python-sh.SlackBuild
index 031a1c58b8..08c32303e2 100644
--- a/python/python-sh/python-sh.SlackBuild
+++ b/python/python-sh/python-sh.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-sh
-# Copyright 2012-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=python-sh
VERSION=${VERSION:-1.12.14}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,7 +57,7 @@ find -L . \
python setup.py install --root=$PKG
-if [ "${PYTHON3:-no}" == "yes" ]; then
+if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi