summaryrefslogtreecommitdiffstats
path: root/development/git-cola/git-cola.SlackBuild
diff options
context:
space:
mode:
author Ricardo J. Barberis <ricardo.barberis@gmail.com>2019-10-05 06:27:07 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-10-05 06:27:07 +0700
commitca7a42b945558f18d1d66b2d755d245fa0eea639 (patch)
tree281679132caca9ed106a8a916f64062cb376203e /development/git-cola/git-cola.SlackBuild
parentcc8cc24095f81670434b0719a99734a47e78e696 (diff)
downloadslackbuilds-ca7a42b945558f18d1d66b2d755d245fa0eea639.tar.gz
slackbuilds-ca7a42b945558f18d1d66b2d755d245fa0eea639.tar.xz
development/git-cola: Updated for version 3.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/git-cola/git-cola.SlackBuild')
-rw-r--r--development/git-cola/git-cola.SlackBuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/development/git-cola/git-cola.SlackBuild b/development/git-cola/git-cola.SlackBuild
index ade84d3b09..ab3796a68b 100644
--- a/development/git-cola/git-cola.SlackBuild
+++ b/development/git-cola/git-cola.SlackBuild
@@ -4,10 +4,10 @@
# Written by Andrew Rowland <darowland@ieee.org>
-# Copyright (c) 2017-2018, Modified by: Ricardo J. Barberis <ricardo.barberis@gmail.com>
+# Copyright (c) 2017-2019, Modified by: Ricardo J. Barberis <ricardo.barberis@gmail.com>
PRGNAM=git-cola
-VERSION=${VERSION:-3.3}
+VERSION=${VERSION:-3.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,12 +53,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
make DESTDIR=$PKG prefix=/usr install
make DESTDIR=$PKG prefix=/usr install-doc
make DESTDIR=$PKG prefix=/usr install-html
+sed -i -e 's,/usr/bin/python.*,/usr/bin/python3,' $PKG/usr/bin/git-cola $PKG/usr/bin/git-dag
+sed -i -e 's,/usr/bin/env python.*,/usr/bin/env python3,' $PKG/usr/share/git-cola/bin/git-xbase \
+ $PKG/usr/share/git-cola/lib/cola/widgets/spellcheck.py
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true