summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author William PC <w_calandrini[at]hotmail[dot]com>2023-03-16 18:55:49 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-03-18 09:50:22 +0700
commita024c5f014cad2e7e5e7f4789d4d2862799bab73 (patch)
treeb720b0c423d290dbf3d41c09d6a92fb5df9161e5 /academic
parentb09715a42e274869be2fde67a3f73ebd32d0a80b (diff)
downloadslackbuilds-a024c5f014cad2e7e5e7f4789d4d2862799bab73.tar.gz
slackbuilds-a024c5f014cad2e7e5e7f4789d4d2862799bab73.tar.xz
academic/pomoxis: Added (bioinformatics tools for nanopore research)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/pomoxis/README4
-rw-r--r--academic/pomoxis/pomoxis.SlackBuild102
-rw-r--r--academic/pomoxis/pomoxis.info10
-rw-r--r--academic/pomoxis/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/academic/pomoxis/README b/academic/pomoxis/README
new file mode 100644
index 0000000000..5214c86dc4
--- /dev/null
+++ b/academic/pomoxis/README
@@ -0,0 +1,4 @@
+ Pomoxis comprises a set of basic bioinformatic tools tailored to
+nanopore sequencing. Notably tools are included for generating and
+analysing draft assemblies. Many of these tools are used by the
+research data analysis group at Oxford Nanopore Technologies.
diff --git a/academic/pomoxis/pomoxis.SlackBuild b/academic/pomoxis/pomoxis.SlackBuild
new file mode 100644
index 0000000000..6c43667b34
--- /dev/null
+++ b/academic/pomoxis/pomoxis.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/bash
+
+# Slackware build script for pomoxis
+
+# Copyright 2023 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=pomoxis
+VERSION=${VERSION:-0.3.12}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+python3 setup.py install --root=$PKG
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.md LICENSE.md docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/pomoxis/pomoxis.info b/academic/pomoxis/pomoxis.info
new file mode 100644
index 0000000000..e78d77e751
--- /dev/null
+++ b/academic/pomoxis/pomoxis.info
@@ -0,0 +1,10 @@
+PRGNAM="pomoxis"
+VERSION="0.3.12"
+HOMEPAGE="https://github.com/nanoporetech/pomoxis"
+DOWNLOAD="https://github.com/nanoporetech/pomoxis/archive/v0.3.12/pomoxis-0.3.12.tar.gz"
+MD5SUM="a2c01f36a87982962143f8d99648a7f1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="blas"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/academic/pomoxis/slack-desc b/academic/pomoxis/slack-desc
new file mode 100644
index 0000000000..8d2494de50
--- /dev/null
+++ b/academic/pomoxis/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pomoxis: pomoxis (bioinformatics tools for nanopore research)
+pomoxis:
+pomoxis:
+pomoxis: Pomoxis comprises a set of basic bioinformatic tools tailored to
+pomoxis: nanopore sequencing. Notably tools are included for generating and
+pomoxis: analysing draft assemblies. Many of these tools are used by the
+pomoxis: research data analysis group at Oxford Nanopore Technologies.
+pomoxis:
+pomoxis:
+pomoxis:
+pomoxis: