summaryrefslogtreecommitdiffstats
path: root/academic/dwave-preprocessing
diff options
context:
space:
mode:
author William PC <w_calandrini[at]hotmail[dot]com>2022-11-06 18:57:19 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-12 22:32:59 +0700
commit403e2641c97ba61715fbfcaf0dd0b9afc113aa52 (patch)
treefa8543f03534c0988a3f034256ca8dd41bce76c5 /academic/dwave-preprocessing
parent4783e23c0474a47a6598a688807728be69c1574a (diff)
downloadslackbuilds-403e2641c97ba61715fbfcaf0dd0b9afc113aa52.tar.gz
slackbuilds-403e2641c97ba61715fbfcaf0dd0b9afc113aa52.tar.xz
academic/dwave-preprocessing: Added (binary quadratic models tools)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/dwave-preprocessing')
-rw-r--r--academic/dwave-preprocessing/README2
-rw-r--r--academic/dwave-preprocessing/dwave-preprocessing.SlackBuild117
-rw-r--r--academic/dwave-preprocessing/dwave-preprocessing.info10
-rw-r--r--academic/dwave-preprocessing/slack-desc19
4 files changed, 148 insertions, 0 deletions
diff --git a/academic/dwave-preprocessing/README b/academic/dwave-preprocessing/README
new file mode 100644
index 0000000000..b0f9a0feab
--- /dev/null
+++ b/academic/dwave-preprocessing/README
@@ -0,0 +1,2 @@
+ dwave-preprocessing is a package of common preprocessing tools that
+can aid in solving binary quadratic models (BQM).
diff --git a/academic/dwave-preprocessing/dwave-preprocessing.SlackBuild b/academic/dwave-preprocessing/dwave-preprocessing.SlackBuild
new file mode 100644
index 0000000000..4314c1f173
--- /dev/null
+++ b/academic/dwave-preprocessing/dwave-preprocessing.SlackBuild
@@ -0,0 +1,117 @@
+#!/bin/bash
+
+# Slackware build script for dwave-preprocessing
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM="dwave-preprocessing"
+VERSION=${VERSION:-0.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+python3 setup.py install --root=$PKG
+
+# run tests
+PYVER=$( python3 -c 'import sys; print( "%d.%d" % sys.version_info[:2] )' )
+cd tests
+ for file in $(ls test_*.py); do
+ echo -n "$file "
+ PYTHONPATH=../build/lib.linux-$(uname -m)-$PYVER python3 $file
+ if [ "$?" -eq "0" ]; then
+ echo "OK"
+ else
+ echo "\n$file - fail"
+ fi
+ done
+cd ..
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.rst docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/dwave-preprocessing/dwave-preprocessing.info b/academic/dwave-preprocessing/dwave-preprocessing.info
new file mode 100644
index 0000000000..6b4a6f3e81
--- /dev/null
+++ b/academic/dwave-preprocessing/dwave-preprocessing.info
@@ -0,0 +1,10 @@
+PRGNAM="dwave-preprocessing"
+VERSION="0.5.0"
+HOMEPAGE="https://www.dwavesys.com"
+DOWNLOAD="https://github.com/dwavesystems/dwave-preprocessing/archive/0.5.0/dwave-preprocessing-0.5.0.tar.gz"
+MD5SUM="68de0e23a6c8023f30f056e5aae2cbfb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="dimod"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/academic/dwave-preprocessing/slack-desc b/academic/dwave-preprocessing/slack-desc
new file mode 100644
index 0000000000..fbf08c0c18
--- /dev/null
+++ b/academic/dwave-preprocessing/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dwave-preprocessing: dwave-preprocessing (preprocessing tools for binary quadratic models)
+dwave-preprocessing:
+dwave-preprocessing:
+dwave-preprocessing: dwave-preprocessing is a package of common preprocessing tools
+dwave-preprocessing: that can aid in solving binary quadratic models (BQM).
+dwave-preprocessing:
+dwave-preprocessing:
+dwave-preprocessing:
+dwave-preprocessing:
+dwave-preprocessing:
+dwave-preprocessing: