summaryrefslogtreecommitdiffstats
path: root/academic/bpp1.9-phyl/bpp1.9-phyl.SlackBuild
diff options
context:
space:
mode:
author Petar Petrov <slackalaxy@gmail.com>2022-09-09 03:07:45 +0100
committer Dave Woodfall <dave@slackbuilds.org>2022-09-09 03:07:45 +0100
commit1f0ff62f35d302c3ca0868682d5475a5b5a80f55 (patch)
tree7e9164155e6d204b78f002406164b4a124cedc35 /academic/bpp1.9-phyl/bpp1.9-phyl.SlackBuild
parent15bcc39c2bb4e99ad8daf69fab2d198ca1ac4130 (diff)
downloadslackbuilds-1f0ff62f35d302c3ca0868682d5475a5b5a80f55.tar.gz
slackbuilds-1f0ff62f35d302c3ca0868682d5475a5b5a80f55.tar.xz
academic/bpp1.9-phyl: Added (Bio++ 1.9 Phyl Library)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'academic/bpp1.9-phyl/bpp1.9-phyl.SlackBuild')
-rw-r--r--academic/bpp1.9-phyl/bpp1.9-phyl.SlackBuild119
1 files changed, 119 insertions, 0 deletions
diff --git a/academic/bpp1.9-phyl/bpp1.9-phyl.SlackBuild b/academic/bpp1.9-phyl/bpp1.9-phyl.SlackBuild
new file mode 100644
index 0000000000..fa951d6f2e
--- /dev/null
+++ b/academic/bpp1.9-phyl/bpp1.9-phyl.SlackBuild
@@ -0,0 +1,119 @@
+#!/bin/bash
+
+# Slackware build script for bpp1.9-phyl
+
+# Copyright 2020-2022 Petar Petrov slackalaxy@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=bpp1.9-phyl
+SRCNAM=bpp-phyl
+VERSION=${VERSION:-1.9.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+LIBDIRPATH="-Wl,-rpath,/usr/lib${LIBDIRSUFFIX}/Bpp1.9"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# CAPS wants TreeTemplateTools to be modified a bit...
+patch -p1 -i $CWD/caps_TreeTemplateTools.patch
+
+# Use custom install place, so libs can coexist with latest bpp
+export PATH="/usr/lib${LIBDIRSUFFIX}/Bpp1.9/:$PATH"
+sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Phyl.spec
+
+source /etc/profile.d/gcc5.sh
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS $LIBDIRPATH" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+ sed -i "s:/lib/:/lib${LIBDIRSUFFIX}/Bpp1.9/:g" Phyl/cmake_install.cmake
+ sed -i "s:/lib\b:/lib${LIBDIRSUFFIX}/Bpp1.9:g" Phyl/cmake_install.cmake
+
+ make
+ make DESTDIR=$PKG install
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+chmod 0644 AUTHORS ChangeLog COPYING
+cp -a \
+ AUTHORS ChangeLog COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE