summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author GUAN Xin <guanx.bac@gmail.com>2024-04-12 22:57:59 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-13 22:03:48 +0700
commit6f9f4c11bd244dcc9475ae572c9bed7890c29b11 (patch)
tree3754fe48564316f78927e13398972c2d6064d783
parentfc36e9a1032dcce5719796b47449fae9d597b0f6 (diff)
downloadslackbuilds-6f9f4c11bd244dcc9475ae572c9bed7890c29b11.tar.gz
slackbuilds-6f9f4c11bd244dcc9475ae572c9bed7890c29b11.tar.xz
network/beegfs: Add development files.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/beegfs/beegfs.SlackBuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/network/beegfs/beegfs.SlackBuild b/network/beegfs/beegfs.SlackBuild
index a730e714da..32e78d13c9 100644
--- a/network/beegfs/beegfs.SlackBuild
+++ b/network/beegfs/beegfs.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=beegfs
VERSION=${VERSION:-7.4.3}
VERSION_MAJOR=$(echo $VERSION | cut -d. -f1,1)
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -133,7 +133,7 @@ install -o 0 -g 0 -d -m 0755 $PKG/sbin
install -o 0 -g 0 -p -m 0755 -t $PKG/sbin utils/scripts/fsck.beegfs
install -o 0 -g 0 -d -m 0755 $PKG/opt/beegfs/src/client/client_module_$VERSION_MAJOR
-cp -at $PKG/opt/beegfs/src/client/client_module_$VERSION_MAJOR client_module/build client_module/source
+cp -at $PKG/opt/beegfs/src/client/client_module_$VERSION_MAJOR client_module/build client_module/include client_module/source
rm -fr $PKG/opt/beegfs/src/client/client_module_$VERSION_MAJOR/build/dist
chown -R 0:0 $PKG/opt/beegfs/src/client/client_module_$VERSION_MAJOR
chmod -R og-w $PKG/opt/beegfs/src/client/client_module_$VERSION_MAJOR
@@ -158,6 +158,13 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# beegfs-client-devel files
+cp -at $PKG/usr client_devel/include
+cp -at $PKG/usr/doc/$PRGNAM-$VERSION client_devel/build/dist/usr/share/doc/beegfs-client-devel
+cat > $PKG/usr/doc/$PRGNAM-$VERSION/beegfs-client-devel/examples/Makefile << EOF
+% : %.cpp
+ \$(CXX) -O2 -Wall -I/opt/beegfs/src/client/client_module_$VERSION_MAJOR/include -o \$@ \$<
+EOF
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc