summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2024-04-08 03:47:16 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-13 22:04:06 +0700
commit29b58269aca48a984a1384d37e7a18aa924ff07b (patch)
treeb6d2da6e515c712921fba087c9b44ad8031ad587
parentaaf377fe172506a8d1ca8c1b40d916c1416effa3 (diff)
downloadslackbuilds-29b58269aca48a984a1384d37e7a18aa924ff07b.tar.gz
slackbuilds-29b58269aca48a984a1384d37e7a18aa924ff07b.tar.xz
python/python3-cffsubr: Fix building on -current.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-cffsubr/python3-cffsubr.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/python3-cffsubr/python3-cffsubr.SlackBuild b/python/python3-cffsubr/python3-cffsubr.SlackBuild
index 53b8cd05f3..c5bf532128 100644
--- a/python/python3-cffsubr/python3-cffsubr.SlackBuild
+++ b/python/python3-cffsubr/python3-cffsubr.SlackBuild
@@ -87,10 +87,14 @@ rm -rvf external
sed -i '/ext_modules=\[tx\]/d; /^ext_modules=/a ext_modules=[]' setup.py
CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+# 46and2: Note that the link creation below does not work and I don't
+# know if it is necessary, but it will now build on current at least.
+
# Create a symlink to installed afdko's tx tool, this is neccessary as
# cffsubr and fontmake needs this symlink to work properly
-ln -s /usr/bin/tx $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/cffsubr/
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+ln -s /usr/bin/tx $PKG/usr/lib${LIBDIRSUFFIX}/python$PYVER/site-packages/cffsubr/
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true