summaryrefslogtreecommitdiffstats
path: root/source/n/php/php.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/n/php/php.SlackBuild')
-rwxr-xr-xsource/n/php/php.SlackBuild11
1 files changed, 1 insertions, 10 deletions
diff --git a/source/n/php/php.SlackBuild b/source/n/php/php.SlackBuild
index 9b7cde933..a37ab12dd 100755
--- a/source/n/php/php.SlackBuild
+++ b/source/n/php/php.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=php
VERSION=${VERSION:-$(echo php-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-ALPINE=2.24
+ALPINE=2.26
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
@@ -155,11 +155,6 @@ zcat $CWD/php-fpm.conf.diff.gz | patch -p1 --verbose || exit 1
# Fix for imap API change:
zcat $CWD/php.imap.api.diff.gz | patch -p1 --verbose || exit 1
-# Use enchant-2:
-zcat $CWD/php.enchant-2.patch.gz | patch -p1 --verbose || exit 1
-export ENCHANT_CFLAGS="-I/usr/include/enchant-2"
-export ENCHANT_LIBS="-lenchant-2"
-
# Install the build folder into /usr/lib$LIBDIRSUFFIX/php/build
# and adapt phpize accordingly:
sed -i "s|build$|php/build|" scripts/Makefile.frag
@@ -190,7 +185,6 @@ CXXFLAGS="$SLKCFLAGS -DU_USING_ICU_NAMESPACE=1 -DU_DEFINE_FALSE_AND_TRUE=1" \
--enable-fpm \
--with-fpm-user=apache \
--with-fpm-group=apache \
- --enable-maintainer-zts \
--enable-pcntl \
--enable-mbregex \
--enable-tokenizer=shared \
@@ -199,7 +193,6 @@ CXXFLAGS="$SLKCFLAGS -DU_USING_ICU_NAMESPACE=1 -DU_DEFINE_FALSE_AND_TRUE=1" \
--with-layout=PHP \
--disable-sigchild \
--with-libxml \
- --with-xmlrpc=shared \
--with-expat \
--enable-simplexml \
--enable-xmlreader=shared \
@@ -251,7 +244,6 @@ CXXFLAGS="$SLKCFLAGS -DU_USING_ICU_NAMESPACE=1 -DU_DEFINE_FALSE_AND_TRUE=1" \
--enable-sysvshm \
--with-xsl=shared,/usr \
--with-zip=shared \
- --with-tsrm-pthreads \
--enable-intl=shared \
--enable-opcache \
--enable-shared=yes \
@@ -343,4 +335,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/php-$VERSION-$ARCH-$BUILD.txz
-