summaryrefslogtreecommitdiffstats
path: root/source/l/python-pillow/python-pillow.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-pillow/python-pillow.SlackBuild')
-rwxr-xr-xsource/l/python-pillow/python-pillow.SlackBuild11
1 files changed, 2 insertions, 9 deletions
diff --git a/source/l/python-pillow/python-pillow.SlackBuild b/source/l/python-pillow/python-pillow.SlackBuild
index 6817cfd5c..84127f415 100755
--- a/source/l/python-pillow/python-pillow.SlackBuild
+++ b/source/l/python-pillow/python-pillow.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2009, 2010, 2013, 2014, 2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2009, 2010, 2013, 2014, 2018, 2020 Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2014 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=python-pillow
VERSION=${VERSION:-$(echo Pillow-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -59,7 +59,6 @@ elif [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
fi
-PYTHONINC=$( python -c 'from distutils.sysconfig import get_python_inc; print(get_python_inc())' )
PYTHON3INC=$( python3 -c 'from distutils.sysconfig import get_python_inc; print(get_python_inc())' )
TMP=${TMP:-/tmp}
@@ -79,12 +78,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-python setup.py install --root=$PKG || exit 1
-
-# install headers
-mkdir -p ${PKG}$PYTHONINC/Imaging
-install -m 644 src/libImaging/*.h ${PKG}$PYTHONINC/Imaging
-
python3 setup.py install --root=$PKG || exit 1
# install headers