summaryrefslogtreecommitdiffstats
path: root/source/l/glade/glade.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/glade/glade.SlackBuild')
-rwxr-xr-xsource/l/glade/glade.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/source/l/glade/glade.SlackBuild b/source/l/glade/glade.SlackBuild
index c47e1cf1e..cda119f2a 100755
--- a/source/l/glade/glade.SlackBuild
+++ b/source/l/glade/glade.SlackBuild
@@ -1,8 +1,8 @@
#!/bin/bash
-# Slackware build script for glade
-
# Copyright 2011, 2020 Robby Workman, Tuscaloosa, Alabama, USA
+# Copyright 2022 Patrick J. Volkerding, Sebeka, MN, USA
+#
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=glade
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-2}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -79,9 +79,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-# Well, this is dumb:
-sed -i "s,python-3.8-embed,python-3.9-embed," meson.build
-
# Configure, build, and install:
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"
@@ -100,6 +97,7 @@ meson setup \
--localstatedir=/var \
--buildtype=release \
-Dgladeui=true \
+ -Dgtk_doc=false \
.. || exit 1
"${NINJA:=ninja}" $NUMJOBS || exit 1
DESTDIR=$PKG $NINJA install || exit 1