summaryrefslogtreecommitdiffstats
path: root/source/d/python2/python2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python2/python2.SlackBuild')
-rwxr-xr-xsource/d/python2/python2.SlackBuild113
1 files changed, 88 insertions, 25 deletions
diff --git a/source/d/python2/python2.SlackBuild b/source/d/python2/python2.SlackBuild
index 42c15d243..4ec28177d 100755
--- a/source/d/python2/python2.SlackBuild
+++ b/source/d/python2/python2.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008, 2009, 2012, 2013, 2016, 2018, 2020 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2012, 2013, 2016, 2018, 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ PKGNAM=python2
SRCNAM=Python
VERSION=$(echo $SRCNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)
BRANCH_VERSION=$(echo $VERSION | cut -f 1,2 -d . )
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-8}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
@@ -97,6 +97,17 @@ find . \
# Enable built-in SQLite module to load extensions
sed -i "/SQLITE_OMIT_LOAD_EXTENSION/d" setup.py
+# If there's no pip2 on the system, assume python2 is not installed and
+# bootstrap from scratch:
+if [ ! -x /usr/bin/pip2 ]; then
+ # If system we're building on already has Python2 with pip in site-packages,
+ # ignore it and install pip anyway.
+ sed -i 's|\("install",\)|\1 "--ignore-installed",|' Lib/ensurepip/__init__.py
+ ENSUREPIP="--with-ensurepip"
+else
+ ENSUREPIP="--without-ensurepip"
+fi
+
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
@@ -108,12 +119,28 @@ sed -i "/SQLITE_OMIT_LOAD_EXTENSION/d" setup.py
--enable-unicode=ucs4 \
--with-system-expat \
--with-system-ffi \
- --without-ensurepip \
+ $ENSUREPIP \
--build=$ARCH-slackware-linux || exit 1
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
+# This conflicts with python3. We'll assume the python3 version is more
+# up-to-date and just get rid of it:
+rm -f $PKG/usr/bin/2to3
+
+# We don't want these now:
+rm -f $PKG/usr/bin/python
+rm -f $PKG/usr/bin/python-config
+
+# Don't package this. We want /usr/bin/pip in the main python-pip package to be
+# the python3 version:
+rm -f $PKG/usr/bin/pip
+
+# It's tempting to get rid of this entirely, but we'll leave the -2.7 versioned
+# binary:
+rm -f $PKG/usr/bin/easy_install
+
# Install some python-demo files:
mkdir -p $PKG/usr/doc/python2-$VERSION
cp -a Demo $PKG/usr/doc/python2-$VERSION
@@ -128,14 +155,6 @@ mv $SITEPK/README $PKG/usr/doc/python2-$VERSION/README.python-tools
ln -sf $TOOLSDIR Tools
)
-# Make a few useful symlinks:
-mkdir -p $PKG/usr/bin
-( cd $PKG/usr/bin
- ln -sf $TOOLSDIR/pynche/pynche pynche
- ln -sf $TOOLSDIR/i18n/msgfmt.py .
- ln -sf $TOOLSDIR/i18n/pygettext.py .
-)
-
# Install docs:
mkdir -p $PKG/usr/doc/python2-$VERSION/Documentation
cp -a README LICENSE $PKG/usr/doc/python2-$VERSION
@@ -151,19 +170,6 @@ chown -R root:root $PKG/usr/doc/python2-$VERSION
find . -perm 750 -exec chmod 755 "{}" \+
)
-
-( cd $PKG/usr/bin
- rm -f python
- ln -sf python${BRANCH_VERSION} python
-)
-
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
-)
-
( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \+
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
@@ -175,9 +181,66 @@ chown -R root:root $PKG/usr/doc/python2-$VERSION
fi
)
+# If python2 isn't already installed, we need to bootstrap it to the system now:
+if [ ! -x /usr/bin/pip2 ]; then
+ ( cd $PKG
+ echo "Bootstrapping..."
+ tar cf - . | ( cd / ; tar xf - )
+ )
+fi
+
+# Bundle the very last pip for python2:
+tar xf $CWD/pip-20.3.tar.lz || exit 1
+cd pip-20.3
+fix_perms
+python2 setup.py install --root=$PKG || exit 1
+# Don't package this. We want /usr/bin/pip in the main python-pip package to be
+# the python3 version:
+rm -f $PKG/usr/bin/pip
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3
+cp -a *.txt PKG-INFO README.rst \
+ $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3
+find $PKG/usr/doc/$PKGNAM-$VERSION/pip-20.3 -type f -exec chmod 0644 {} \+
+cd ..
+
+# Bundle the very last setuptools for python2:
+tar xf $CWD/setuptools-44.1.1.tar.lz || exit 1
+cd setuptools-44.1.1
+fix_perms
+# Install setuptools to the system if it's not there:
+if [ ! -d /usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/setuptools/version.py ]; then
+ python2 setup.py install --root=/ || exit 1
+fi
+python2 setup.py install --root=$PKG || exit 1
+# It's tempting to get rid of this entirely, but we'll leave the -2.7 versioned
+# binary:
+rm -f $PKG/usr/bin/easy_install
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1
+cp -a CHANGES.rst PKG-INFO README.rst docs/*.txt \
+ $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1
+find $PKG/usr/doc/$PKGNAM-$VERSION/setuptools-44.1.1 -type f -exec chmod 0644 {} \+
+# If there's a CHANGES.rst, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r CHANGES.rst ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION/setuptools-44.1.1)
+ cat CHANGES.rst | head -n 1000 > $DOCSDIR/CHANGES.rst
+ touch -r CHANGES.rst $DOCSDIR/CHANGES.rst
+fi
+cd ..
+
+# Remove Windows garbage:
+find $PKG . -name "*.exe" -exec rm -f "{}" \;
+find $PKG . -name "*.dll" -exec rm -f "{}" \;
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/python2-$VERSION-$ARCH-$BUILD.txz
-