summaryrefslogtreecommitdiffstats
path: root/source/d/python-setuptools/python-setuptools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python-setuptools/python-setuptools.SlackBuild')
-rwxr-xr-xsource/d/python-setuptools/python-setuptools.SlackBuild35
1 files changed, 23 insertions, 12 deletions
diff --git a/source/d/python-setuptools/python-setuptools.SlackBuild b/source/d/python-setuptools/python-setuptools.SlackBuild
index 366b4f9c5..2c5b99d13 100755
--- a/source/d/python-setuptools/python-setuptools.SlackBuild
+++ b/source/d/python-setuptools/python-setuptools.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 2013-2014 Audrius Kažukauskas <audrius@neutrino.lt>
-# Copyright 2014, 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2014, 2017, 2018, 2022, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,6 @@
cd $(dirname $0) ; CWD=$(pwd)
-# First, convert the .zip file if needed:
-if ls *.zip 1> /dev/null 2> /dev/null ; then
- unzip *.zip
- tar cf $(basename *.zip .zip).tar $(basename *.zip .zip)
- touch -r *.zip *.tar
- plzip -9 *.tar
- rm -r $(basename *.zip .zip)
- rm *.zip
-fi
-
PKGNAM=python-setuptools
VERSION=${VERSION:-$(echo setuptools-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
@@ -47,6 +37,21 @@ if [ -z "$ARCH" ]; then
esac
fi
+if [ "$ARCH" = "i586" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "armv7hl" ]; then
+ LIBDIRSUFFIX=""
+else
+ LIBDIRSUFFIX=""
+fi
+
+
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
@@ -73,7 +78,13 @@ find -L . \
rm -f setuptools/*.exe
-python3 setup.py install --root=$PKG || exit 1
+# Sticking with setup.py while it exists to make it easier to bootstrap a
+# new Python version:
+python3 setup.py build install --root=$PKG || exit 1
+
+# Don't use this. ;-)
+#unshare -n python3 -m build --wheel --no-isolation || exit 1
+#python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a CHANGES.rst PKG-INFO README.rst docs/*.txt \