summaryrefslogtreecommitdiffstats
path: root/source/d/python-setuptools/python-setuptools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python-setuptools/python-setuptools.SlackBuild')
-rwxr-xr-xsource/d/python-setuptools/python-setuptools.SlackBuild24
1 files changed, 0 insertions, 24 deletions
diff --git a/source/d/python-setuptools/python-setuptools.SlackBuild b/source/d/python-setuptools/python-setuptools.SlackBuild
index 2e926666e..2c5b99d13 100755
--- a/source/d/python-setuptools/python-setuptools.SlackBuild
+++ b/source/d/python-setuptools/python-setuptools.SlackBuild
@@ -23,16 +23,6 @@
cd $(dirname $0) ; CWD=$(pwd)
-# First, convert the .zip file if needed:
-if ls *.zip 1> /dev/null 2> /dev/null ; then
- unzip *.zip
- tar cf $(basename *.zip .zip).tar $(basename *.zip .zip)
- touch -r *.zip *.tar
- plzip -9 *.tar
- rm -r $(basename *.zip .zip)
- rm *.zip
-fi
-
PKGNAM=python-setuptools
VERSION=${VERSION:-$(echo setuptools-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
@@ -88,20 +78,6 @@ find -L . \
rm -f setuptools/*.exe
-# After Python 3.9, we will not mess with the upstream module layout again.
-if python3 --version | grep -q "Python 3.9." ; then
- # Recent Python versions support both a libdir (for pure Python modules) and a
- # platlib (for $ARCH specific modules). We've always patched Python to use
- # the platform directory (such as /usr/lib64/python3.9/site-packages on x86_64)
- # for all modules. Perhaps we will rethink this, but since an installed
- # setuptools now takes priority for reporting the libdir (and this no longer
- # matches the platlib on architectures such as x86_64), let's patch setuptools
- # to agree with Python:
- if [ "$LIBDIRSUFFIX" = "64" ]; then
- zcat $CWD/setuptools.x86_64.diff.gz | patch -p1 --verbose || exit 1
- fi
-fi
-
# Sticking with setup.py while it exists to make it easier to bootstrap a
# new Python version:
python3 setup.py build install --root=$PKG || exit 1