summaryrefslogtreecommitdiffstats
path: root/source/d/python-pip/python-pip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python-pip/python-pip.SlackBuild')
-rwxr-xr-xsource/d/python-pip/python-pip.SlackBuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/source/d/python-pip/python-pip.SlackBuild b/source/d/python-pip/python-pip.SlackBuild
index 1ee81c396..deaefdbbe 100755
--- a/source/d/python-pip/python-pip.SlackBuild
+++ b/source/d/python-pip/python-pip.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2017, 2018, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2017 Heinz Wiesinger, Amsterdam, NL
# All rights reserved.
#
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=python-pip
VERSION=${VERSION:-$(echo pip-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-3}
SRCNAM=pip
@@ -61,7 +61,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG || exit 1
+# Sticking with setup.py while it exists to make it easier to bootstrap a
+# new Python version:
+python3 setup.py build install --root=$PKG || exit 1
+
+# Don't use this. ;-)
+#unshare -n python3 -m build --wheel --no-isolation || exit 1
+#python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
+
+# Remove Windows garbage:
+find $PKG . -name "*.exe" -exec rm -f "{}" \;
+find $PKG . -name "*.dll" -exec rm -f "{}" \;
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.txt PKG-INFO README.rst \