summaryrefslogtreecommitdiffstats
path: root/source/d/binutils/binutils.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/binutils/binutils.SlackBuild')
-rwxr-xr-xsource/d/binutils/binutils.SlackBuild40
1 files changed, 15 insertions, 25 deletions
diff --git a/source/d/binutils/binutils.SlackBuild b/source/d/binutils/binutils.SlackBuild
index ff401137a..24e9b9be3 100755
--- a/source/d/binutils/binutils.SlackBuild
+++ b/source/d/binutils/binutils.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2005-2021 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2005-2022 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -107,44 +107,34 @@ zcat $CWD/patches/binutils-no-config-h-check.patch.gz | patch -p1 --verbose || e
# Set %version to something halfway meaningful:
zcat $CWD/patches/binutils-version.patch.gz | patch -p1 --verbose || exit 1
-sed -i -e 's/%''{release}/slack15/g' bfd/Makefile{.am,.in}
-
-# Use the "unsigned long long" type for pointers on hosts where long is a
-# 32-bit type but pointers are a 64-bit type. Necessary because users expect
-# to be able to install both the x86 and x86_64 versions of binutils on the
-# same machine, so they need identical versions of the bfd.h header file.
-zcat $CWD/patches/binutils-use-long-long.patch.gz | patch -p1 --verbose || exit 1
+sed -i -e 's/%''{release}/slack151/g' bfd/Makefile{.am,.in}
# Work around a bug caused by binutils using an ancient libtool:
zcat $CWD/patches/binutils-libtool-lib64.patch.gz | patch -p1 --verbose || exit 1
# Various regression fixes:
zcat $CWD/patches/binutils-2.27-aarch64-ifunc.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/patches/binutils-CVE-2019-1010204.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/patches/binutils-bfd-close-fds.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-do-not-link-with-static-libstdc++.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/patches/binutils-dwarf-5-dir0.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-filename-in-error-messages.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/patches/binutils-fix-testsuite-failures.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-gold-i386-gnu-property-notes.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-gold-mismatched-section-flags.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-gold-warn-unsupported.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/patches/binutils-missing-man-pages.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-readelf-other-sym-info.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/patches/binutils-revert-PLT-elision.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-special-sections-in-groups.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-testsuite-fixes.patch.gz | patch -p1 --verbose || exit 1
-# Thanks to Fedora:
-# Dependencies are not set up to rebuild the configure files
-# in the subdirectories. So we just rebuild the ones we care
-# about after applying the configure patches
-pushd libiberty
-autoconf
-popd
-pushd intl
-autoconf
-popd
+## COMMENTED OUT as nothing touches configure-related files in these
+## directories, and the latest autoconf isn't working to rebuild them.
+## Thanks to Fedora:
+## Dependencies are not set up to rebuild the configure files
+## in the subdirectories. So we just rebuild the ones we care
+## about after applying the configure patches
+#pushd libiberty
+#autoconf
+#popd
+#pushd intl
+#autoconf
+#popd
chown -R root:root .
find . \
@@ -172,7 +162,7 @@ CFLAGS="$SLKCFLAGS" \
--enable-64-bit-bfd \
--enable-plugins \
--enable-threads \
- --enable-targets=i386-efi-pe,${TARGET} \
+ --enable-targets=i386-efi-pe,bpf-unknown-none,${TARGET} \
--enable-install-libiberty \
--enable-gold=yes \
--enable-ld=default \