summaryrefslogtreecommitdiffstats
path: root/source/d/Cython/Cython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/Cython/Cython.SlackBuild')
-rwxr-xr-xsource/d/Cython/Cython.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/source/d/Cython/Cython.SlackBuild b/source/d/Cython/Cython.SlackBuild
index d2893f072..6e8bcae7b 100755
--- a/source/d/Cython/Cython.SlackBuild
+++ b/source/d/Cython/Cython.SlackBuild
@@ -1,8 +1,7 @@
#!/bin/bash
-# Slackware build script for Cython
-
# Copyright 2015 Robby Workman, Tuscaloosa, Alabama, USA
+# Copyright 2024 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -61,7 +60,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-python3 setup.py install --root=$PKG --prefix=/usr || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
# Make cython3 symlink:
if [ ! -x $PKG/usr/bin/cython3 ]; then