summaryrefslogtreecommitdiffstats
path: root/source/l/system-config-printer/system-config-printer.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2024-01-09 01:52:43 +0000
committer Eric Hameleers <alien@slackware.com>2024-01-09 03:31:52 +0100
commit09504fc48447542878036d98e868b525789c7bc6 (patch)
tree365d93793ee4dcd6b33f7e3c5b712c96ed5dc72b /source/l/system-config-printer/system-config-printer.SlackBuild
parent360a12d5d90dc285bebff21b774cea64dffe1ca4 (diff)
downloadcurrent-09504fc48447542878036d98e868b525789c7bc6.tar.gz
current-09504fc48447542878036d98e868b525789c7bc6.tar.xz
Tue Jan 9 01:52:43 UTC 202420240109015243
a/procps-ng-3.3.17-x86_64-3.txz: Rebuilt. Add /etc/default/sysctl to support custom options for sysctl in rc.S. Thanks to lostintime. a/sysvinit-scripts-15.1-noarch-12.txz: Rebuilt. rc.S: support /etc/default/sysctl for custom options. Thanks to lostintime. l/imagemagick-7.1.1_26-x86_64-1.txz: Upgraded. l/qt5-5.15.12_20240103_b8fd1448-x86_64-1.txz: Upgraded. n/samba-4.19.4-x86_64-1.txz: Upgraded. x/imake-1.0.10-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/l/system-config-printer/system-config-printer.SlackBuild')
-rwxr-xr-xsource/l/system-config-printer/system-config-printer.SlackBuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/source/l/system-config-printer/system-config-printer.SlackBuild b/source/l/system-config-printer/system-config-printer.SlackBuild
index 15b5a60b8..c8782bafa 100755
--- a/source/l/system-config-printer/system-config-printer.SlackBuild
+++ b/source/l/system-config-printer/system-config-printer.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 2010, 2011, 2012 Eric Hameleers, Eindhoven, NL
-# Copyright 2010, 2011, 2012, 2013, 2018, 2020, 2021, 2022 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2010, 2011, 2012, 2013, 2018, 2020, 2021, 2022, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -113,6 +113,7 @@ PYTHON=/usr/bin/python3 \
--docdir=/usr/doc/$PKGNAM-$VERSION \
--localstatedir=/var/lib \
--sysconfdir=/etc \
+ --with-udevdir=/lib/udev \
--with-udev-rules \
--with-systemdsystemunitdir=no \
--program-prefix= \
@@ -134,14 +135,10 @@ python3 setup.py install --root=$PKG || exit 1
python3 -m compileall "${PKG}/usr/share/system-config-printer"
python3 -O -m compileall "${PKG}/usr/share/system-config-printer"
-# Move the udev files to the usual Slackware location:
-mkdir -p $PKG/lib
-mv $PKG/etc/udev $PKG/lib/
-
# Move the dbus configs to the system location:
mkdir -p $PKG/usr/share/dbus-1/system.d/
mv $PKG/etc/dbus-1/system.d/* $PKG/usr/share/dbus-1/system.d/
-rmdir --parents $PKG/etc/dbus-1/system.d/
+rm -rf $PKG/etc/dbus-1
if [ ! -L /lib${LIBDIRSUFFIX}/libpam.so.? ]; then
# Looks like PAM is not installed. Instead, your user must be in group 'lp'.