summaryrefslogtreecommitdiffstats
path: root/source/l/python-pytz/python-pytz.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2022-04-30 21:35:21 +0000
committer Eric Hameleers <alien@slackware.com>2022-05-01 06:59:45 +0200
commit9b4be22e71a5affdb921f8ab706fbd12b27c40e0 (patch)
tree657af4cce782959f24514c947f5d884c5b2bb417 /source/l/python-pytz/python-pytz.SlackBuild
parent6e7367558a81e9565a69e3657c01a624dec5e892 (diff)
downloadcurrent-20220430213521.tar.gz
current-20220430213521.tar.xz
Sat Apr 30 21:35:21 UTC 202220220430213521
a/btrfs-progs-5.17-x86_64-1.txz: Upgraded. l/libgsf-1.14.49-x86_64-1.txz: Upgraded. l/mozilla-nss-3.78-x86_64-1.txz: Upgraded. l/oniguruma-6.9.8-x86_64-1.txz: Upgraded. l/python-alabaster-0.7.12-x86_64-1.txz: Added. l/python-babel-2.10.1-x86_64-1.txz: Added. l/python-imagesize-1.3.0-x86_64-1.txz: Added. l/python-importlib_metadata-4.11.3-x86_64-1.txz: Added. l/python-pytz-2022.1-x86_64-1.txz: Added. l/python-snowballstemmer-2.2.0-x86_64-1.txz: Added. l/python-sphinx-4.5.0-x86_64-1.txz: Added. l/python-zipp-3.8.0-x86_64-1.txz: Added. n/ModemManager-1.18.8-x86_64-1.txz: Upgraded. x/libX11-1.8-x86_64-1.txz: Upgraded. xap/pidgin-2.14.9-x86_64-1.txz: Upgraded. Mitigate the potential for a man in the middle attack via DNS spoofing by removing the code that supported the _xmppconnect DNS TXT record. For more information, see: https://www.pidgin.im/about/security/advisories/cve-2022-26491/ https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-26491 (* Security fix *)
Diffstat (limited to 'source/l/python-pytz/python-pytz.SlackBuild')
-rwxr-xr-xsource/l/python-pytz/python-pytz.SlackBuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/source/l/python-pytz/python-pytz.SlackBuild b/source/l/python-pytz/python-pytz.SlackBuild
new file mode 100755
index 000000000..0dc07f739
--- /dev/null
+++ b/source/l/python-pytz/python-pytz.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Copyright 2022 Patrick J. Volkerding, Sebeka, MN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PKGNAM=python-pytz
+SRCNAM=pytz
+VERSION=${VERSION:-$(echo ${SRCNAM}-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-1}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-$PKGNAM
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z || exit 1
+cd $SRCNAM-$VERSION || exit 1
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG || exit 1
+
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
+cp -a *.rst LICENSE* NOTICE PKG-INFO \
+ $PKG/usr/doc/$PKGNAM-$VERSION
+find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \+
+
+# If there's a HISTORY.rst, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r HISTORY.rst ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
+ cat HISTORY.rst | head -n 1000 > $DOCSDIR/HISTORY.rst
+ touch -r HISTORY.rst $DOCSDIR/HISTORY.rst
+fi
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz