summaryrefslogtreecommitdiffstats
path: root/source/l/gtk+3/gtk+3.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2022-12-09 19:43:46 +0000
committer Eric Hameleers <alien@slackware.com>2022-12-09 21:38:57 +0100
commit9969c19137bda499690b440ddb516d3608e40044 (patch)
treebdaaf3e3d3e750bcf78b19700ab8e2649bfa06b0 /source/l/gtk+3/gtk+3.SlackBuild
parent69f7fbdfae263c407ef01858ec9bd77eb071bafd (diff)
downloadcurrent-9969c19137bda499690b440ddb516d3608e40044.tar.gz
current-9969c19137bda499690b440ddb516d3608e40044.tar.xz
Fri Dec 9 19:43:46 UTC 202220221209194346
a/usbutils-015-x86_64-1.txz: Upgraded. l/adwaita-icon-theme-43-noarch-1.txz: Upgraded. l/gtk+3-3.24.35-x86_64-1.txz: Upgraded. l/libarchive-3.6.2-x86_64-1.txz: Upgraded. This is a bugfix and security release. Relevant bugfixes: rar5 reader: fix possible garbled output with bsdtar -O (#1745) mtree reader: support reading mtree files with tabs (#1783) Security fixes: various small fixes for issues found by CodeQL (* Security fix *) l/mozilla-nss-3.86-x86_64-1.txz: Upgraded. l/pipewire-0.3.62-x86_64-1.txz: Upgraded. x/OpenCC-1.1.6-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/l/gtk+3/gtk+3.SlackBuild')
-rwxr-xr-xsource/l/gtk+3/gtk+3.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/source/l/gtk+3/gtk+3.SlackBuild b/source/l/gtk+3/gtk+3.SlackBuild
index 740909808..c8e50c591 100755
--- a/source/l/gtk+3/gtk+3.SlackBuild
+++ b/source/l/gtk+3/gtk+3.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008, 2009, 2010, 2011, 2013, 2018, 2020 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2011, 2013, 2018, 2020, 2022 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -85,6 +85,11 @@ zcat $CWD/gtk.fix.missing.version-check.py.diff.gz | patch -p1 --verbose || exit
# Loosen this up for gcc11:
zcat $CWD/gtk.array-bounds.gcc11.diff.gz | patch -p1 --verbose || exit 1
+# If this is missing:
+if [ ! -r gdk/wayland/cursor/meson.build ]; then
+ zcat $CWD/fix.missing.gdk.wayland.cursor.meson.build.diff.gz | patch -p1 --verbose || exit 1
+fi
+
# Configure, build, and install:
export CFLAGS="$SLKCFLAGS -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"
export CXXFLAGS="$SLKCFLAGS -DG_ENABLE_DEBUG -DG_DISABLE_CAST_CHECKS"