summaryrefslogtreecommitdiffstats
path: root/source/d/binutils/binutils.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2022-08-10 18:50:54 +0000
committer Eric Hameleers <alien@slackware.com>2022-08-11 07:00:16 +0200
commit26d50f213699b051562ecb7d443127a4f1ba2f7e (patch)
tree769bba2b98e65ea1a6623b66f959be01eb45cc24 /source/d/binutils/binutils.SlackBuild
parenta5f98c65b12d21d81311e9d572cccb765e44b93f (diff)
downloadcurrent-26d50f213699b051562ecb7d443127a4f1ba2f7e.tar.gz
current-26d50f213699b051562ecb7d443127a4f1ba2f7e.tar.xz
Wed Aug 10 18:50:54 UTC 202220220810185054
a/kernel-firmware-20220810_ad5ae82-noarch-1.txz: Upgraded. d/binutils-2.39-x86_64-1.txz: Upgraded. d/oprofile-1.4.0-x86_64-10.txz: Rebuilt. Recompiled against binutils-2.39. l/gdk-pixbuf2-2.42.9-x86_64-1.txz: Upgraded. l/nodejs-18.7.0-x86_64-1.txz: Upgraded. Might as well go with the latest version of this since everyone else does. Fixed a sed substitution to get the correct lib${LIBDIRSUFFIX} in npm.js. Thanks to conraid and zerouno. n/gpgme-1.18.0-x86_64-1.txz: Upgraded. n/libnftnl-1.2.3-x86_64-1.txz: Upgraded. n/nfs-utils-2.6.2-x86_64-1.txz: Upgraded. n/nftables-1.0.5-x86_64-1.txz: Upgraded.
Diffstat (limited to 'source/d/binutils/binutils.SlackBuild')
-rwxr-xr-xsource/d/binutils/binutils.SlackBuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/source/d/binutils/binutils.SlackBuild b/source/d/binutils/binutils.SlackBuild
index f4733e492..8edcd5b41 100755
--- a/source/d/binutils/binutils.SlackBuild
+++ b/source/d/binutils/binutils.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2005-2021 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2005-2022 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=binutils
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
MARCH=$( uname -m )
@@ -109,18 +109,11 @@ zcat $CWD/patches/binutils-no-config-h-check.patch.gz | patch -p1 --verbose || e
zcat $CWD/patches/binutils-version.patch.gz | patch -p1 --verbose || exit 1
sed -i -e 's/%''{release}/slack151/g' bfd/Makefile{.am,.in}
-# Use the "unsigned long long" type for pointers on hosts where long is a
-# 32-bit type but pointers are a 64-bit type. Necessary because users expect
-# to be able to install both the x86 and x86_64 versions of binutils on the
-# same machine, so they need identical versions of the bfd.h header file.
-zcat $CWD/patches/binutils-use-long-long.patch.gz | patch -p1 --verbose || exit 1
-
# Work around a bug caused by binutils using an ancient libtool:
zcat $CWD/patches/binutils-libtool-lib64.patch.gz | patch -p1 --verbose || exit 1
# Various regression fixes:
zcat $CWD/patches/binutils-2.27-aarch64-ifunc.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/patches/binutils-CVE-2019-1010204.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-do-not-link-with-static-libstdc++.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-filename-in-error-messages.patch.gz | patch -p1 --verbose || exit 1
zcat $CWD/patches/binutils-gold-i386-gnu-property-notes.patch.gz | patch -p1 --verbose || exit 1
@@ -170,7 +163,7 @@ CFLAGS="$SLKCFLAGS" \
--enable-64-bit-bfd \
--enable-plugins \
--enable-threads \
- --enable-targets=i386-efi-pe,${TARGET} \
+ --enable-targets=i386-efi-pe,bpf-unknown-none,${TARGET} \
--enable-install-libiberty \
--enable-gold=yes \
--enable-ld=default \