summaryrefslogtreecommitdiffstats
path: root/source/a/util-linux/util-linux.SlackBuild
diff options
context:
space:
mode:
author Patrick J Volkerding <volkerdi@slackware.com>2012-09-26 01:10:42 +0000
committer Eric Hameleers <alien@slackware.com>2018-05-31 22:51:55 +0200
commit9664bee729d487bcc0a0bc35859f8e13d5421c75 (patch)
treeb428a16618e36ed864a8d76ea3435e19a452bf90 /source/a/util-linux/util-linux.SlackBuild
parent75a4a592e5ccda30715f93563d741b83e0dcf39e (diff)
downloadcurrent-slackware-14.0.tar.gz
current-slackware-14.0.tar.xz
Slackware 14.0slackware-14.0
Wed Sep 26 01:10:42 UTC 2012 Slackware 14.0 x86_64 stable is released! We're perfectionists here at Slackware, so this release has been a long time a-brewing. But we think you'll agree that it was worth the wait. Slackware 14.0 combines modern components, ease of use, and flexible configuration... our "KISS" philosophy demands it. The ISOs are off to be replicated, a 6 CD-ROM 32-bit set and a dual-sided 32-bit/64-bit x86/x86_64 DVD. Please consider supporting the Slackware project by picking up a copy from store.slackware.com. We're taking pre-orders now, and offer a discount if you sign up for a subscription. Thanks to everyone who helped make this happen. The Slackware team, the upstream developers, and (of course) the awesome Slackware user community. Have fun! :-)
Diffstat (limited to 'source/a/util-linux/util-linux.SlackBuild')
-rwxr-xr-xsource/a/util-linux/util-linux.SlackBuild38
1 files changed, 25 insertions, 13 deletions
diff --git a/source/a/util-linux/util-linux.SlackBuild b/source/a/util-linux/util-linux.SlackBuild
index 424199144..1fa74c832 100755
--- a/source/a/util-linux/util-linux.SlackBuild
+++ b/source/a/util-linux/util-linux.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008, 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2011, 2012 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,9 +23,9 @@
# Slackware build script for util-linux
VERSION=${VERSION:-$(echo util-linux*.tar.?z* | cut -d - -f 3 | rev | cut -f 3- -d . | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-5}
-ADJTIMEXVERS=1.23
+ADJTIMEXVERS=1.29
SETSERIALVERS=2.17
ZIPTOOLVERS=1.4.0
@@ -70,8 +70,7 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Disabled login and init stuff from being built, as this is provided by
-# shadow and sysvinit
+# Disabled login stuff from being built, as this is provided by shadow
#
# /sbin/elvtune is not built, as configure says it only works with 2.2 and
# 2.4 kernels
@@ -85,7 +84,19 @@ find . \
# Changing the fdisk -l output (this was done prior to util-linux-ng) broke
# our installation scripts, so we have changed the name of partition type
# 83 back to "Linux swap":
-zcat $CWD/util-linux.fdisk-no-solaris.diff.gz | patch -p1 || exit 1
+zcat $CWD/util-linux.fdisk-no-solaris.diff.gz | patch -p1 --verbose || exit 1
+
+# Fix loop encryption:
+zcat $CWD/0001-mount-old-fix-encryption-usage.patch.gz | patch -p1 --verbose || exit 1
+
+# Fix fdisk granularity on 512 byte sector size devices:
+zcat $CWD/0002-fdisk-don-t-ignore-1MiB-granularity-on-512-byte-sect.patch.gz | patch -p1 --verbose || exit 1
+
+# 20120814 bkw: fix "column --separator <anything>" segfault
+zcat $CWD/column-fix_long_opts.diff.gz | patch -p1 --verbose || exit 1
+
+# Regenerate, since patch 0001 hits mount/Makefile.am:
+./autogen.sh
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -99,9 +110,9 @@ CFLAGS="$SLKCFLAGS" \
--disable-static \
--enable-arch \
--enable-agetty \
- --disable-init \
--enable-kill \
--disable-last \
+ --enable-line \
--enable-mesg \
--enable-partx \
--enable-raw \
@@ -114,8 +125,10 @@ CFLAGS="$SLKCFLAGS" \
--enable-use-tty-group \
--enable-libblkid \
--enable-libmount \
+ --enable-libmount-mount \
--enable-libuuid \
--disable-uuidd \
+ --enable-ddate \
--build=$ARCH-slackware-linux \
|| exit 1
@@ -180,11 +193,10 @@ cat strings.1 | gzip -9c > $PKG/usr/man/man1/strings.1.gz
# Add just the hostname utilities from net-tools, so that anyone
# installing just the A series will not have a hostname (null):
cd $TMP || exit 1
-rm -rf net-tools-1.60
-tar xvf $CWD/net-tools-1.60.tar.xz
-cd net-tools-1.60
-zcat $CWD/net-tools_1.60-19.diff.gz | patch -p1 || exit
-zcat $CWD/net-tools.diff.gz | patch -p1 || exit
+rm -rf net-tools-1.60.20120726git
+tar xvf $CWD/net-tools-1.60.20120726git.tar.xz
+cd net-tools-1.60.20120726git
+zcat $CWD/net-tools.config.h.gz > config.h
make
make hostname
strip hostname
@@ -209,7 +221,7 @@ rm -rf adjtimex-$ADJTIMEXVERS
tar xvf $CWD/adjtimex_${ADJTIMEXVERS}.orig.tar.gz || exit 1
cd adjtimex-$ADJTIMEXVERS || exit 1
chown -R root:root .
-zcat $CWD/adjtimex_1.23-1.diff.gz | patch -p1 || exit 1
+zcat $CWD/adjtimex_1.29-2.2.diff.gz | patch -p1 || exit 1
CFLAGS=-O2 ./configure --prefix=/usr || exit 1
make || exit 1
strip adjtimex