summaryrefslogtreecommitdiffstats
path: root/libreoffice/build/libreoffice.SlackBuild
diff options
context:
space:
mode:
author Eric Hameleers <alien@slackware.com>2019-10-09 07:11:34 +0000
committer Eric Hameleers <alien@slackware.com>2019-10-09 07:11:34 +0000
commit1de2dcdeda67379ea828667037a835fe1158390a (patch)
tree3cca893339d674620704321bb2a44b2fe3c0cb4c /libreoffice/build/libreoffice.SlackBuild
parent228106c98b35d111e93ab36e72a4e0c55ba86fb5 (diff)
downloadasb-1de2dcdeda67379ea828667037a835fe1158390a.tar.gz
asb-1de2dcdeda67379ea828667037a835fe1158390a.tar.xz
libreoffice: updated to 6.3.2
Diffstat (limited to 'libreoffice/build/libreoffice.SlackBuild')
-rwxr-xr-xlibreoffice/build/libreoffice.SlackBuild35
1 files changed, 25 insertions, 10 deletions
diff --git a/libreoffice/build/libreoffice.SlackBuild b/libreoffice/build/libreoffice.SlackBuild
index 9e73193b..7a74c0a5 100755
--- a/libreoffice/build/libreoffice.SlackBuild
+++ b/libreoffice/build/libreoffice.SlackBuild
@@ -294,6 +294,8 @@
# * Update.
# 6.3.0-1: 25/aug/2019 by Eric Hameleers <alien@slackware.com>
# * Update.
+# 6.3.2-1: 07/oct/2019 by Eric Hameleers <alien@slackware.com>
+# * Update.
#
# Run 'sh libreoffice.SlackBuild' to build a Slackware package.
# The package (.txz) and .txt file as well as build logs are created in /tmp .
@@ -329,8 +331,8 @@ ADD_KDE5=$(echo $ADD_KDE5 | tr 'a-z' 'A-Z')
#SRCVER=${SRCVER:-5.0.0.2git}
#SRCVER=${SRCVER:-5.0.0.2}
-SRCVER=${SRCVER:-6.3.0}
-SUBVER=".4"
+SRCVER=${SRCVER:-6.3.2}
+SUBVER=".2"
PKG_SUBVER=""
# Under what directory will the script download all sources:
@@ -460,7 +462,7 @@ GITURI[5]=""
#
# --- Start of section generated by gensrc.sh ---
-# External sources for libreoffice-6.3.0.4
+# External sources for libreoffice-6.3.2.2
SOURCE[6]="$SRCDIR/${LOSRC_DIR}/185d60944ea767075d27247c3162b3bc-unowinreg.dll"
SRCURL[6]="https://dev-www.libreoffice.org/extern/185d60944ea767075d27247c3162b3bc-unowinreg.dll"
@@ -470,8 +472,8 @@ SOURCE[7]="$SRCDIR/${LOSRC_DIR}/884ed41809687c3e168fc7c19b16585149ff058eca79acbf
SRCURL[7]="https://dev-www.libreoffice.org/extern/884ed41809687c3e168fc7c19b16585149ff058eca79acbf3ee784f6630704cc-opens___.ttf"
GITURI[7]=""
-SOURCE[8]="$SRCDIR/${LOSRC_DIR}/libabw-0.1.2.tar.xz"
-SRCURL[8]="https://dev-www.libreoffice.org/src/libabw-0.1.2.tar.xz"
+SOURCE[8]="$SRCDIR/${LOSRC_DIR}/libabw-0.1.3.tar.xz"
+SRCURL[8]="https://dev-www.libreoffice.org/src/libabw-0.1.3.tar.xz"
GITURI[8]=""
SOURCE[9]="$SRCDIR/${LOSRC_DIR}/commons-logging-1.2-src.tar.gz"
@@ -930,8 +932,8 @@ SOURCE[122]="$SRCDIR/${LOSRC_DIR}/0168229624cfac409e766913506961a8-ucpp-1.3.2.ta
SRCURL[122]="https://dev-www.libreoffice.org/src/0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz"
GITURI[122]=""
-SOURCE[123]="$SRCDIR/${LOSRC_DIR}/libvisio-0.1.6.tar.xz"
-SRCURL[123]="https://dev-www.libreoffice.org/src/libvisio-0.1.6.tar.xz"
+SOURCE[123]="$SRCDIR/${LOSRC_DIR}/libvisio-0.1.7.tar.xz"
+SRCURL[123]="https://dev-www.libreoffice.org/src/libvisio-0.1.7.tar.xz"
GITURI[123]=""
SOURCE[124]="$SRCDIR/${LOSRC_DIR}/libwpd-0.10.3.tar.xz"
@@ -1172,9 +1174,9 @@ if [ "$P1" != "--oldbuild" ]; then
# Add support for KDE5 destop session:
cat $SRCDIR/patches/libreoffice.kde5_mailer.patch \
| patch -p1 --verbose 2>&1 | tee -a $OUTPUT/patch-$PRGNAM.log
- # Fix a build failure for 6.3.0.4:
- cat $SRCDIR/patches/libreoffice63.calendar_class.patch \
- | patch -p1 --verbose 2>&1 | tee -a $OUTPUT/patch-$PRGNAM.log
+ ## Fix a build failure for 6.3.0.4:
+ #cat $SRCDIR/patches/libreoffice63.calendar_class.patch \
+ # | patch -p1 --verbose 2>&1 | tee -a $OUTPUT/patch-$PRGNAM.log
### Rather. I will disable postgresql-sdbc for -current,
# because I can not get it to compile against openssl-1.1 at all...
#if openssl-1.0 version 1>/dev/null 2>/dev/null ; then
@@ -1182,6 +1184,10 @@ if [ "$P1" != "--oldbuild" ]; then
# cat $SRCDIR/patches/postgresql_openssl10.patch | sed -e "s/@LIBDIRSUFFIX@/$LIBDIRSUFFIX/" \
# | patch -p1 --verbose 2>&1 | tee -a $OUTPUT/patch-$PRGNAM.log
#fi
+ # Make libfreehand compile against icu4c-65.1:
+ cp $SRCDIR/patches/libfreehand_icu_65.1.patch external/libfreehand/
+ echo '$(eval $(call gb_UnpackedTarball_add_patches,libfreehand, external/libfreehand/libfreehand_icu_65.1.patch))' \
+ >> external/libfreehand/UnpackedTarball_libfreehand.mk
fi
if [ "${USE_LOVER}" == "yes" ]; then
@@ -1401,6 +1407,15 @@ echo "Installing XML files because 'make distro-pack-install' fails to do so..."
mkdir -p $PKG/usr/share/appdata
install -m644 sysui/desktop/appstream-appdata/*.xml $PKG/usr/share/appdata/
+# Triggered by Arch Linux (thanks Andreas Radke):
+# Make all i18n lang packages with help section ('1') available to
+# fix "F1" not opening translated offline help opening in browser
+# see also /usr/lib${LIBDIRSUFFFIX}/libreoffice/help/en-US/langnames.js
+if [ ! -f $PKG/usr/lib${LIBDIRSUFFIX}/libreoffice/help/languages.js ]; then
+ echo "var languagesSet = new Set(['en-US', 'ar', 'bg', 'bn', 'bo', 'bs', 'ca', 'cs', 'da', 'de', 'el', 'en-GB', 'eo', 'es', 'et', 'eu', 'fi', 'fr', 'gl', 'he', 'hi', 'hr', 'hu', 'id', 'is', 'it', 'ja', 'ko', 'lt', 'lv', 'nb', 'nl', 'nn', 'pl', 'pt', 'pt-BR', 'ro', 'ru', 'si', 'sk', 'sl', 'sv', 'ta', 'tr', 'uk', 'vi', 'zh-CN', 'zh-TW']);" \
+ > $PKG/usr/lib${LIBDIRSUFFIX}/libreoffice/help/languages.js
+fi
+
# Remove cruft:
rm -f $PKG/gid_Module*