summaryrefslogtreecommitdiffstats
path: root/source.local/l/loudmouth/loudmouth.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source.local/l/loudmouth/loudmouth.SlackBuild')
-rwxr-xr-xsource.local/l/loudmouth/loudmouth.SlackBuild84
1 files changed, 40 insertions, 44 deletions
diff --git a/source.local/l/loudmouth/loudmouth.SlackBuild b/source.local/l/loudmouth/loudmouth.SlackBuild
index f1bed54..e38e922 100755
--- a/source.local/l/loudmouth/loudmouth.SlackBuild
+++ b/source.local/l/loudmouth/loudmouth.SlackBuild
@@ -1,5 +1,6 @@
#!/bin/sh
# Copyright 2009 Eric Hameleers, Eindhoven, NL
+# Copyright 2012 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Permission to use, copy, modify, and distribute this software for
@@ -25,43 +26,39 @@
PKGNAM=loudmouth
-VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+VERSION=${VERSION:-1.5.0-20121201}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:" -j4 "}
-# Automatically determine the architecture we're building on:
-MARCH=$( uname -m )
-if [ -z "$ARCH" ]; then
- case "$MARCH" in
- i?86) export ARCH=i486 ;;
- armv7hl) export ARCH=$MARCH ;;
- arm*) export ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) export ARCH=$MARCH ;;
- esac
-fi
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- SLKLDFLAGS=""
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
- SLKLDFLAGS=""
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- SLKLDFLAGS="-L/usr/lib64"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "armv7hl" ]; then
- SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
- SLKLDFLAGS=""
- LIBDIRSUFFIX=""
+if [ -e $CWD/machine.conf ]; then
+ . $CWD/machine.conf ]
+elif [ -e /etc/slackbuild/machine.conf ]; then
+ . /etc/slackbuild/machine.conf ]
else
- SLKCFLAGS="-O2"
- SLKLDFLAGS=""
- LIBDIRSUFFIX=""
+ # Automatically determine the architecture we're building on:
+ if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+ fi
+ # Set CFLAGS/CXXFLAGS and LIBDIRSUFFIX:
+ if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+ elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+ elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+ else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+ fi
fi
case "$ARCH" in
@@ -80,14 +77,7 @@ rm -rf $PKGNAM-$VERSION
tar xvf $CWD/$PKGNAM-$VERSION.tar.?z* || exit 1
cd $PKGNAM-$VERSION || exit 1
-zcat $CWD/loudmouth.crtpath.diff.gz | patch -p1 --verbose || exit 1
-zcat $CWD/loudmouth.gnutls.configure.ac.diff.gz | patch -p1 --verbose || exit 1
-zcat $CWD/loudmouth.async_assertion.diff.gz | patch -p1 --verbose || exit 1
-zcat $CWD/loudmouth.sasl-md5-digest-uri.diff.gz | patch -p1 --verbose || exit 1
-zcat $CWD/loudmouth.stanzadrop.diff.gz | patch -p1 --verbose || exit 1
-
-# needed after the configure.ac gnutls patch
-autoreconf
+zcat $CWD/loudmouth.ld.gobject.diff.gz | patch -p1 --verbose || exit 1
# Make sure ownerships and permissions are sane:
chown -R root:root .
@@ -108,15 +98,21 @@ LDFLAGS="$SLKLDFLAGS" \
--mandir=/usr/man \
--docdir=/usr/doc/$PKGNAM-$VERSION \
--with-ssl=gnutls \
- --enable-debug=no \
+ --enable-debug=yes \
--enable-static=no \
+ --enable-gtk-doc \
--program-prefix= \
--program-suffix= \
--build=$TARGET \
--host=$TARGET
-# this generates a broken libtool, so use the system version:
-cp /usr/bin/libtool .
+##
+## NOTE: For some reason --enable-debug=yes actually _disables_ verbose debug
+## messages to the console. Don't mess with it!
+##
+
+## this generates a broken libtool, so use the system version:
+#cp /usr/bin/libtool .
# Build and install:
make $NUMJOBS || make || exit 1
@@ -149,5 +145,5 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
# Build package:
cd $PKG
-/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
+/sbin/makepkg -l y -c n $TMP/$PKGNAM-$(echo $VERSION | tr - _)-$ARCH-$BUILD.txz