summaryrefslogtreecommitdiffstats
path: root/source.local/l/libdbusmenu-qt/libdbusmenu-qt.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source.local/l/libdbusmenu-qt/libdbusmenu-qt.SlackBuild')
-rwxr-xr-xsource.local/l/libdbusmenu-qt/libdbusmenu-qt.SlackBuild71
1 files changed, 37 insertions, 34 deletions
diff --git a/source.local/l/libdbusmenu-qt/libdbusmenu-qt.SlackBuild b/source.local/l/libdbusmenu-qt/libdbusmenu-qt.SlackBuild
index 1794d15..7dcebcd 100755
--- a/source.local/l/libdbusmenu-qt/libdbusmenu-qt.SlackBuild
+++ b/source.local/l/libdbusmenu-qt/libdbusmenu-qt.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
-# Copyright 2010 Eric Hameleers, Eindhoven, The Netherlands
-# Copyright 2010 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2010, 2011, 2012, 2013 Eric Hameleers, Eindhoven, The Netherlands
+# Copyright 2010, 2011, 2012, 2013 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
# Redistribution and use of this script, with or without modification, is
@@ -21,8 +21,6 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Modified 2012 by Eric Hameleers <alien at slackware.com> for ARM port.
-
# Pull this package from git due to some copyright related
# problems going on at Canonical...
@@ -32,38 +30,39 @@
# grep dbusmenu_qt_VERSION dbusmenu-qt/CMakeLists.txt
PKGNAM=libdbusmenu-qt
-VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
-
-NUMJOBS=${NUMJOBS:--j6}
-
-# Automatically determine the architecture we're building on:
-MARCH=$( uname -m )
-if [ -z "$ARCH" ]; then
- case "$MARCH" in
- i?86) export ARCH=i486 ;;
- armv7hl) export ARCH=$MARCH ;;
- arm*) export ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) export ARCH=$MARCH ;;
- esac
-fi
+VERSION=${VERSION:-0.9.2}
+BUILD=${BUILD:-2}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "armv7hl" ]; then
- SLKCFLAGS="-O2 -march=armv7-a -mfpu=vfpv3-d16"
- LIBDIRSUFFIX=""
+NUMJOBS=${NUMJOBS:--j7}
+
+if [ -e $CWD/machine.conf ]; then
+ . $CWD/machine.conf ]
+elif [ -e /etc/slackbuild/machine.conf ]; then
+ . /etc/slackbuild/machine.conf ]
else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
+ # Automatically determine the architecture we're building on:
+ if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+ fi
+ # Set CFLAGS/CXXFLAGS and LIBDIRSUFFIX:
+ if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+ elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+ elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+ else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+ fi
fi
CWD=$(pwd)
@@ -106,6 +105,10 @@ cp -a \
COPYING NEWS README \
$PKG/usr/doc/$PKGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/doc
+mv $PKG/usr/share/doc/dbusmenu-qt/* $PKG/usr/doc/$PKGNAM-$VERSION/doc
+rm -rf $PKG/usr/share/doc
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc