summaryrefslogtreecommitdiffstats
path: root/system/mount-zip/mount-zip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/mount-zip/mount-zip.SlackBuild')
-rw-r--r--system/mount-zip/mount-zip.SlackBuild35
1 files changed, 14 insertions, 21 deletions
diff --git a/system/mount-zip/mount-zip.SlackBuild b/system/mount-zip/mount-zip.SlackBuild
index c09d8c68fe..2c4bd5daf3 100644
--- a/system/mount-zip/mount-zip.SlackBuild
+++ b/system/mount-zip/mount-zip.SlackBuild
@@ -2,26 +2,15 @@
# Slackware build script for mount-zip
-# Copyright 2022 Charadon
-# Copyright 2023 B. Watson
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Original author: Charadon
+# Modified and now maintained by B. Watson (urchlay@slackware.uk).
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20240209 bkw:
+# - update for v1.0.12.
+# - relicense as WTFPL with permission from Charadon.
+# - add man page, now that there is one.
# 20230828 bkw: take over maintenance, update for v1.0.9.
# - actually use SLKCFLAGS.
@@ -32,7 +21,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mount-zip
-VERSION=${VERSION:-1.0.9}
+VERSION=${VERSION:-1.0.12}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -98,6 +87,10 @@ sed -i "/^CXXFLAGS/s,-O2,$SLKCFLAGS," Makefile lib/Makefile
make
install -s -Dm755 mount-zip $PKG/usr/bin/mount-zip
+# 20240209 bkw: upstream now ships a man page.
+mkdir -p $PKG/usr/man/man1
+gzip -9c < $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
rm -f INSTALL.md
cp -a LICENSE changelog *.md $PKG/usr/doc/$PRGNAM-$VERSION