summaryrefslogtreecommitdiffstats
path: root/desktop/pypanel/pypanel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/pypanel/pypanel.SlackBuild')
-rw-r--r--desktop/pypanel/pypanel.SlackBuild37
1 files changed, 22 insertions, 15 deletions
diff --git a/desktop/pypanel/pypanel.SlackBuild b/desktop/pypanel/pypanel.SlackBuild
index 9bdcb58c20..3e7de35a31 100644
--- a/desktop/pypanel/pypanel.SlackBuild
+++ b/desktop/pypanel/pypanel.SlackBuild
@@ -1,46 +1,53 @@
#!/bin/sh
# Slackware build script for pypanel
-# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
+# Originally written by Vasilis Papavasileiou
+# <el03020 at mail dot ntua dot gr>
# Modified by the SlackBuilds.org project
+# and Chess Griffin <chess@chessgriffin.com>
PRGNAM=pypanel
VERSION=2.4
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+ARCH=i486 # See note below
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+
+# Re ARCH, this will use whatever CFLAGS python was compiled with, so...
+# Since this contains some C code, you will get an i486 package when
+# building on official Slackware. Adjust as appropriate.
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
ORIG_PRGNAM=PyPanel
-DOCS="COPYING PKG-INFO README"
-PYTHON_VERSION=${PYTHON_VERSION:-2.4}
+DOCS="COPYING PKG-INFO README pypanelrc"
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-fi
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $ORIG_PRGNAM-$VERSION
-tar -xzvf $CWD/$ORIG_PRGNAM-$VERSION.tar.gz || exit 1
+tar xvf $CWD/$ORIG_PRGNAM-$VERSION.tar.gz
cd $ORIG_PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-CFLAGS="$SLKCFLAGS" \
- python setup.py build || exit 1
+# Uncomment the patch line below if you want the STARTUP_DELAY
+# variable. This introduces a new configuration file variable called
+# STARTUP_DELAY which will make pypanel load after an interval of
+# time. This is useful in case the window manager is slow to load up
+# before pypanel starts.
+#patch < $CWD/loaddelay.patch
python setup.py install --root $PKG || exit 1
( cd $PKG
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -48,7 +55,7 @@ cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
# Remove docs from site-packages
-rm $PKG/usr/lib/python${PYTHON_VERSION}/site-packages/${PRGNAM}/{COPYING,README}
+rm $PKG/usr/lib/python?.?/site-packages/${PRGNAM}/{COPYING,README}
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc