summaryrefslogtreecommitdiffstats
path: root/academic/labplot2/labplot2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/labplot2/labplot2.SlackBuild')
-rw-r--r--academic/labplot2/labplot2.SlackBuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/academic/labplot2/labplot2.SlackBuild b/academic/labplot2/labplot2.SlackBuild
index c1da77ddf7..90b9c916fc 100644
--- a/academic/labplot2/labplot2.SlackBuild
+++ b/academic/labplot2/labplot2.SlackBuild
@@ -1,8 +1,10 @@
#!/bin/bash
#
# Slackware build script for LabPlot
-# Based on the Slackware 14.1 SlackBuild and AUR PKGBUILD for labplot
-# Written by Fellype do Nascimento <fellype(at)gmail.com>
+# Based on the Slackware 15.0 SlackBuild and AUR PKGBUILD for labplot
+#
+# Copyright 2014-2022, Fellype do Nascimento, Guaratingueta - Brazil
+# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -25,7 +27,7 @@ NAME=labplot
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=labplot2
-VERSION=${VERSION:-2.4.0}
+VERSION=${VERSION:-2.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -87,18 +89,17 @@ find -L . | xargs -O file | grep "shared object" | grep ELF | cut -f 1 -d : | xa
find -L . | xargs -O file | grep "current ar archive" | cut -f 1 -d : | xargs strip -g 2> /dev/null || true
)
+find $PKG/usr/share/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/share/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL README \
+cp -a AUTHORS ChangeLog COPYING INSTALL README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-if [ -e /usr/bin/requiredbuilder ]; then
- requiredbuilder -v -y -s $CWD $PKG
-fi
-
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE