summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Erich Ritz <erich.public@protonmail.com>2022-02-25 13:52:42 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-26 08:58:13 +0700
commite4525bada54193f43e1c7e51b93c99d79e56cb90 (patch)
treefd218d68af4c87980d942eeb47f449207f5c10b4 /system
parentb96ed2eca7464f9553d58aee8f0e76a88f0554fa (diff)
downloadslackbuilds-e4525bada54193f43e1c7e51b93c99d79e56cb90.tar.gz
slackbuilds-e4525bada54193f43e1c7e51b93c99d79e56cb90.tar.xz
system/Solaar: Fix udev rules file and move to correct location.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/Solaar/README2
-rw-r--r--system/Solaar/Solaar.SlackBuild13
2 files changed, 7 insertions, 8 deletions
diff --git a/system/Solaar/README b/system/Solaar/README
index 9c6b8509f9..8904b00ecd 100644
--- a/system/Solaar/README
+++ b/system/Solaar/README
@@ -12,7 +12,7 @@ devices, extra settings (usually not available through the standard
Linux system configuration) are supported.
By default, the udev rule
-/etc/udev/rules.d/42-logitech-unifying-receiver.rules
+/lib/udev/rules.d/42-logitech-unifying-receiver.rules
allows all members of the plugdev group to have read/write access to the
Unifying Receiver device. Therefore, make sure all desktop users are
part of the plugdev group:
diff --git a/system/Solaar/Solaar.SlackBuild b/system/Solaar/Solaar.SlackBuild
index 8e8e40bbeb..8a058b07cf 100644
--- a/system/Solaar/Solaar.SlackBuild
+++ b/system/Solaar/Solaar.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Solaar
-# Copyright 2019-2020 Erich Ritz, Scottsdale, Arizona, USA
+# Copyright 2019-2022 Erich Ritz, Jenks, Oklahoma, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -71,12 +68,14 @@ find -L . \
python3 setup.py install --root=$PKG
-mkdir -p $PKG/etc/udev/rules.d
-cp -a rules.d/42-logitech-unify-permissions.rules $PKG/etc/udev/rules.d
+mkdir -p $PKG/lib/udev/rules.d
+mv $PKG/usr/share/solaar/udev-rules.d/42-logitech-unify-permissions.rules $PKG/lib/udev/rules.d
+rmdir $PKG/usr/share/solaar/udev-rules.d
+sed -i 's/#MODE="0660", GROUP="plugdev"/MODE="0660", GROUP="plugdev"/g' $PKG/lib/udev/rules.d/42-logitech-unify-permissions.rules
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- COPYING COPYRIGHT ChangeLog README.md \
+ COPYING COPYRIGHT ChangeLog README.md Release_Notes docs \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild