summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Marek Wodzinski <majek@w7i.pl>2024-02-17 08:33:29 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-17 09:03:04 +0700
commitb53bdbaa99b5fef54245251e1efec285f7ea50c5 (patch)
treeeaa09536f165721fb441f803dbbded00e694167f /system
parente19486a933a9d571a7380a3abdc23981a82e1048 (diff)
downloadslackbuilds-b53bdbaa99b5fef54245251e1efec285f7ea50c5.tar.gz
slackbuilds-b53bdbaa99b5fef54245251e1efec285f7ea50c5.tar.xz
system/ansible-core: Added (Ansible core).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/ansible-core/README5
-rw-r--r--system/ansible-core/ansible-core.SlackBuild92
-rw-r--r--system/ansible-core/ansible-core.info10
-rw-r--r--system/ansible-core/slack-desc19
4 files changed, 126 insertions, 0 deletions
diff --git a/system/ansible-core/README b/system/ansible-core/README
new file mode 100644
index 0000000000..282f8b19a1
--- /dev/null
+++ b/system/ansible-core/README
@@ -0,0 +1,5 @@
+Ansible Core is the language and runtime that powers automation.
+
+Core includes the Ansible language and runtime,
+a set of built-in modules and command-line tools,
+and a framework for extending automation with collections.
diff --git a/system/ansible-core/ansible-core.SlackBuild b/system/ansible-core/ansible-core.SlackBuild
new file mode 100644
index 0000000000..fba03e2c59
--- /dev/null
+++ b/system/ansible-core/ansible-core.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/bash
+
+# Slackware build script for ansible-core
+
+# Copyright 2024 Marek Wodzinski <majek@w7i.pl>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=ansible-core
+VERSION=${VERSION:-2.15.9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.md licenses/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/ansible-core/ansible-core.info b/system/ansible-core/ansible-core.info
new file mode 100644
index 0000000000..63eecc2a28
--- /dev/null
+++ b/system/ansible-core/ansible-core.info
@@ -0,0 +1,10 @@
+PRGNAM="ansible-core"
+VERSION="2.15.9"
+HOMEPAGE="https://www.ansible.com"
+DOWNLOAD="https://files.pythonhosted.org/packages/47/0b/5e46aeee6c72adc3507d9909e57fa1e9a66b3f4929c463bdbe102441a062/ansible-core-2.15.9.tar.gz"
+MD5SUM="101644e55f0f2e13630aeaba3809298f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cryptography importlib-resources python3-resolvelib"
+MAINTAINER="Marek Wodzinski"
+EMAIL="majek@w7i.pl"
diff --git a/system/ansible-core/slack-desc b/system/ansible-core/slack-desc
new file mode 100644
index 0000000000..f24ce06215
--- /dev/null
+++ b/system/ansible-core/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ansible-core: ansible-core (language and runtime that powers automation)
+ansible-core:
+ansible-core: Core includes the Ansible language and runtime,
+ansible-core: a set of built-in modules and command-line tools,
+ansible-core: and a framework for extending automation with collections.
+ansible-core:
+ansible-core: Homepage: https://www.ansible.com
+ansible-core:
+ansible-core:
+ansible-core:
+ansible-core: