summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Eugene Wissner <belka@caraus.de>2022-12-22 21:22:07 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-22 21:22:07 +0700
commit8caecf7531a15813a7cefa8c7f7746c38f11e742 (patch)
tree40b4930d937ccd7ec546df402ad6af4ea4c7df13 /system
parenta08ddd52d9de01ec90801d4db01e791edaea681b (diff)
downloadslackbuilds-8caecf7531a15813a7cefa8c7f7746c38f11e742.tar.gz
slackbuilds-8caecf7531a15813a7cefa8c7f7746c38f11e742.tar.xz
system/rdiff-backup: Updated for version 2.2.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/rdiff-backup/README33
-rw-r--r--system/rdiff-backup/rdiff-backup.SlackBuild10
-rw-r--r--system/rdiff-backup/rdiff-backup.info12
3 files changed, 32 insertions, 23 deletions
diff --git a/system/rdiff-backup/README b/system/rdiff-backup/README
index fc58cd77c0..0d5c202d04 100644
--- a/system/rdiff-backup/README
+++ b/system/rdiff-backup/README
@@ -1,13 +1,20 @@
-rdiff-backup backs up one directory to another, possibly over a
-network. The target directory ends up a copy of the source directory,
-but extra reverse diffs are stored in a special subdirectory of that
-target directory, so you can still recover files lost some time
-ago. The idea is to combine the best features of a mirror and an
-incremental backup. rdiff-backup also preserves subdirectories, hard
-links, dev files, permissions, uid/gid ownership, modification times,
-extended attributes, acls, and resource forks. Also, rdiff-backup
-can operate in a bandwidth efficient manner over a pipe, like
-rsync. Thus you can use rdiff-backup and ssh to securely back a
-hard drive up to a remote location, and only the differences will
-be transmitted. Finally, rdiff-backup is easy to use and settings
-have sensical defaults.
+rdiff-backup is a simple backup tool which can be used locally and
+remotely, on Linux and Windows, and even cross-platform between both.
+Users have reported using it successfully on FreeBSD and MacOS X.
+
+Beside its ease of use, one of the main advantages of rdiff-backup is
+that it does use the same efficient protocol as rsync to transfer and
+store data. Because rdiff-backup only stores the differences from the
+previous backup to the next one (a so called reverse incremental
+backup), the latest backup is always a full backup, making it easiest
+and fastest to restore the most recent backups, combining the space
+advantages of incremental backups while keeping the speed advantages
+of full backups (at least for recent ones).
+
+If the optional (runtime) dependencies pylibacl and pyxattr are
+installed, rdiff-backup will support Access Control Lists and Extended
+Attributes provided the file system(s) also support these features.
+
+IMPORTANT: rdiff-backup 2.x is wire-incompatible with versions 1.x, for
+local backups there's no problem but if you backup remotely you have to
+use the same version of rdiff-backup in the client and server.
diff --git a/system/rdiff-backup/rdiff-backup.SlackBuild b/system/rdiff-backup/rdiff-backup.SlackBuild
index cba7a159b1..89500a4f41 100644
--- a/system/rdiff-backup/rdiff-backup.SlackBuild
+++ b/system/rdiff-backup/rdiff-backup.SlackBuild
@@ -1,6 +1,8 @@
#!/bin/bash
# Slackware build script for rdiff-backup
+# Copyright 2022 Eugene Wissner, Germany, Dachau
+#
# Copyright (C) 2007 paul wisehart wise@lupulin.net
# All rights reserved.
#
@@ -26,7 +28,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=rdiff-backup
-VERSION=${VERSION:-1.2.8}
+VERSION=${VERSION:-2.2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,7 +67,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i 's|share/man/|man/|g' setup.py || exit 1
-python setup.py install --prefix=/usr --root=$PKG || exit 1
+python3 setup.py install --prefix=/usr --root=$PKG || exit 1
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -76,10 +78,10 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
)
mkdir -p $PKG/usr/doc
-mv $PKG/usr/share/doc/$PRGNAM-$VERSION $PKG/usr/doc
+mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
cp -a examples.html $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-rm -rf $PKG/usr/share
+rm -rf $PKG/usr/share/doc
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/system/rdiff-backup/rdiff-backup.info b/system/rdiff-backup/rdiff-backup.info
index fe58d9070b..e90de91c4c 100644
--- a/system/rdiff-backup/rdiff-backup.info
+++ b/system/rdiff-backup/rdiff-backup.info
@@ -1,10 +1,10 @@
PRGNAM="rdiff-backup"
-VERSION="1.2.8"
-HOMEPAGE="http://rdiff-backup.nongnu.org/"
-DOWNLOAD="http://savannah.nongnu.org/download/rdiff-backup/rdiff-backup-1.2.8.tar.gz"
-MD5SUM="1a94dc537fcf74d6a3a80bd27808e77b"
+VERSION="2.2.0"
+HOMEPAGE="https://rdiff-backup.net/"
+DOWNLOAD="https://download.dlackware.com/hosted-sources/rdiff-backup/rdiff-backup-2.2.0.tar.gz"
+MD5SUM="92c3e7eb091df503fa5225dc4dc62b38"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="librsync"
-MAINTAINER="Ricardo J. Barberis"
-EMAIL="ricardo.barberis@gmail.com"
+MAINTAINER="Eugene Wissner"
+EMAIL="belka@caraus.de"