summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
author Andrzej Telszewski <andrzej@telszewski.com>2023-12-03 17:43:57 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-09 07:50:05 +0700
commit4fae5d62a5eeab07d7b4888f930b7e88748f107a (patch)
tree045f5dedfb05e735ae1f3ab538b0511d24828841 /system
parent7ae0b81011304dbe9080fbeec554bcf62d08ffb7 (diff)
downloadslackbuilds-4fae5d62a5eeab07d7b4888f930b7e88748f107a.tar.gz
slackbuilds-4fae5d62a5eeab07d7b4888f930b7e88748f107a.tar.xz
system/borgmatic: Added (backup software).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system')
-rw-r--r--system/borgmatic/README6
-rw-r--r--system/borgmatic/borgmatic.SlackBuild78
-rw-r--r--system/borgmatic/borgmatic.info10
-rw-r--r--system/borgmatic/slack-desc19
4 files changed, 113 insertions, 0 deletions
diff --git a/system/borgmatic/README b/system/borgmatic/README
new file mode 100644
index 0000000000..7ee14372a8
--- /dev/null
+++ b/system/borgmatic/README
@@ -0,0 +1,6 @@
+borgmatic is simple, configuration-driven backup software for servers
+and workstations. Protect your files with client-side encryption.
+Backup your databases too. Monitor it all with integrated third-party
+services.
+
+borgmatic uses BorgBackup (Borg) under the hood.
diff --git a/system/borgmatic/borgmatic.SlackBuild b/system/borgmatic/borgmatic.SlackBuild
new file mode 100644
index 0000000000..5de1de36bb
--- /dev/null
+++ b/system/borgmatic/borgmatic.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/bash
+
+# Slackware build script for borgmatic
+
+# Copyright 2023 Andrzej Telszewski, Koszalin
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=borgmatic
+VERSION=${VERSION:-1.8.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+chmod -R a-st,u+rwX,go-w+rX .
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/etc/borgmatic
+mkdir -p $PKG/etc/borgmatic.d
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE NEWS {README,SECURITY}.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > \
+ $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/borgmatic/borgmatic.info b/system/borgmatic/borgmatic.info
new file mode 100644
index 0000000000..0351f6cb0e
--- /dev/null
+++ b/system/borgmatic/borgmatic.info
@@ -0,0 +1,10 @@
+PRGNAM="borgmatic"
+VERSION="1.8.5"
+HOMEPAGE="https://torsion.org/borgmatic/"
+DOWNLOAD="https://github.com/borgmatic-collective/borgmatic/archive/refs/tags/1.8.5.tar.gz"
+MD5SUM="2fd9db3e930fb54164ba943295ebcd23"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="borgbackup colorama python3-ruamel.yaml"
+MAINTAINER="Andrzej Telszewski"
+EMAIL="andrzej@telszewski.com"
diff --git a/system/borgmatic/slack-desc b/system/borgmatic/slack-desc
new file mode 100644
index 0000000000..6a293a602d
--- /dev/null
+++ b/system/borgmatic/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+borgmatic: borgmatic (configuration-driven backup software)
+borgmatic:
+borgmatic: borgmatic is simple, configuration-driven backup software for servers
+borgmatic: and workstations. Protect your files with client-side encryption.
+borgmatic: Backup your databases too. Monitor it all with integrated third-party
+borgmatic: services.
+borgmatic:
+borgmatic: Homepage: https://torsion.org/borgmatic/
+borgmatic:
+borgmatic:
+borgmatic: