summaryrefslogtreecommitdiffstats
path: root/system/set_rlimits/Makefile.patch
diff options
context:
space:
mode:
author Paul Wisehart <wise@lupulin.net>2010-05-13 00:41:46 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-13 00:41:46 +0200
commite550883348ce9fa59b969b6997bcd1f5132a1785 (patch)
tree2293fd9522b3cde6c9dc2a5daf12cebe133eecad /system/set_rlimits/Makefile.patch
parent6623346a8ad98715b143fa6e4816d9313afcdf45 (diff)
downloadslackbuilds-e550883348ce9fa59b969b6997bcd1f5132a1785.tar.gz
slackbuilds-e550883348ce9fa59b969b6997bcd1f5132a1785.tar.xz
system/set_rlimits: Updated for version 1.3.0
Diffstat (limited to 'system/set_rlimits/Makefile.patch')
-rw-r--r--system/set_rlimits/Makefile.patch50
1 files changed, 33 insertions, 17 deletions
diff --git a/system/set_rlimits/Makefile.patch b/system/set_rlimits/Makefile.patch
index f0963dc62b..398356aa39 100644
--- a/system/set_rlimits/Makefile.patch
+++ b/system/set_rlimits/Makefile.patch
@@ -1,29 +1,45 @@
---- Makefile 2007-04-22 14:18:21.000000000 -0400
-+++ Makefile.new 2007-04-22 14:31:49.000000000 -0400
-@@ -12,16 +12,16 @@
- gcc -Wall -g -o set_rlimits set_rlimits.c
+diff -Nur set_rlimits-1.3.0.orig/Makefile set_rlimits-1.3.0/Makefile
+--- set_rlimits-1.3.0.orig/Makefile 2008-05-15 05:44:21.000000000 -0500
++++ set_rlimits-1.3.0/Makefile 2009-07-14 01:43:10.829342025 -0500
+@@ -4,6 +4,10 @@
+ # C compiler to use
+ CC=gcc
+
++# CFLAGS to use
++CFLAGS = -Wall -g
++EXTRA_CFLAGS =
++
+ # Installation locations. If SYSCONFDIR is changed, the CONFIG_FILE define
+ # in set_rtlimits.c will need changing to match.
+ PREFIX=/usr/local
+@@ -12,19 +16,19 @@
+ all: set_rlimits
+
+ set_rlimits: set_rlimits.c
+- $(CC) -Wall -g -o set_rlimits set_rlimits.c
++ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -o set_rlimits set_rlimits.c
install: set_rlimits
- test -d $(PREFIX)/bin || mkdir -p $(PREFIX)/bin
- test -d $(PREFIX)/man/man8 || mkdir -p $(PREFIX)/man/man8
- test -d $(SYSCONFDIR) || mkdir -p $(SYSCONFDIR)
- cp -p set_rlimits $(PREFIX)/bin/
-- chown root.root $(PREFIX)/bin/set_rlimits
+- chown 0.0 $(PREFIX)/bin/set_rlimits
- chmod u+s $(PREFIX)/bin/set_rlimits
- test -e $(SYSCONFDIR)/set_rlimits.conf || cp set_rlimits.conf $(SYSCONFDIR)/
-- chown root.root $(SYSCONFDIR)/set_rlimits.conf
+- chown 0.0 $(SYSCONFDIR)/set_rlimits.conf
- cp -p set_rlimits.8 $(PREFIX)/man/man8/
-- chown root.root $(PREFIX)/man/man8/set_rlimits.8
-+ test -d $(DESTDIR)$(PREFIX)/bin || mkdir -p $(DESTDIR)$(PREFIX)/bin
-+ test -d $(DESTDIR)$(PREFIX)/man/man8 || mkdir -p $(DESTDIR)$(PREFIX)/man/man8
-+ test -d $(DESTDIR)$(SYSCONFDIR) || mkdir -p $(DESTDIR)$(SYSCONFDIR)
-+ cp -p set_rlimits $(DESTDIR)$(PREFIX)/bin/
-+ chown root.root $(DESTDIR)$(PREFIX)/bin/set_rlimits
-+ chmod u+s $(DESTDIR)$(PREFIX)/bin/set_rlimits
-+ test -e $(DESTDIR)$(SYSCONFDIR)/set_rlimits.conf || cp set_rlimits.conf $(DESTDIR)$(SYSCONFDIR)/
-+ chown root.root $(DESTDIR)$(SYSCONFDIR)/set_rlimits.conf
-+ cp -p set_rlimits.8 $(DESTDIR)$(PREFIX)/man/man8/
-+ chown root.root $(DESTDIR)$(PREFIX)/man/man8/set_rlimits.8
+- chown 0.0 $(PREFIX)/man/man8/set_rlimits.8
++ test -d $(DESTDIR)/$(PREFIX)/bin || mkdir -p $(DESTDIR)/$(PREFIX)/bin
++ test -d $(DESTDIR)/$(PREFIX)/man/man8 || mkdir -p $(DESTDIR)/$(PREFIX)/man/man8
++ test -d $(DESTDIR)/$(SYSCONFDIR) || mkdir -p $(DESTDIR)/$(SYSCONFDIR)
++ cp -p set_rlimits $(DESTDIR)/$(PREFIX)/bin/
++ chown 0.0 $(DESTDIR)/$(PREFIX)/bin/set_rlimits
++ chmod u+s $(DESTDIR)/$(PREFIX)/bin/set_rlimits
++ test -e $(DESTDIR)/$(SYSCONFDIR)/set_rlimits.conf || cp set_rlimits.conf $(DESTDIR)/$(SYSCONFDIR)/
++ chown 0.0 $(DESTDIR)/$(SYSCONFDIR)/set_rlimits.conf
++ cp -p set_rlimits.8 $(DESTDIR)/$(PREFIX)/man/man8/
++ chown 0.0 $(DESTDIR)/$(PREFIX)/man/man8/set_rlimits.8
.PHONY: clean tidy