summaryrefslogtreecommitdiffstats
path: root/system/nvidia-legacy96-driver/Makefile-libXNVCtrl
diff options
context:
space:
mode:
author Edward Koenig <kingbeowulf@gmail.com>2013-07-07 21:26:22 -0500
committer Robby Workman <rworkman@slackbuilds.org>2013-07-14 17:07:16 -0500
commit6c513cb06e5a188279c9c6360f950c067b133767 (patch)
treec5193f3c62670625c10c0f0c132aa4c1e20d4332 /system/nvidia-legacy96-driver/Makefile-libXNVCtrl
parentf9c2de67549f14816b7058a8fe15b27953afbecb (diff)
downloadslackbuilds-6c513cb06e5a188279c9c6360f950c067b133767.tar.gz
slackbuilds-6c513cb06e5a188279c9c6360f950c067b133767.tar.xz
system/nvidia-legacy96-driver: Added.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'system/nvidia-legacy96-driver/Makefile-libXNVCtrl')
-rw-r--r--system/nvidia-legacy96-driver/Makefile-libXNVCtrl32
1 files changed, 32 insertions, 0 deletions
diff --git a/system/nvidia-legacy96-driver/Makefile-libXNVCtrl b/system/nvidia-legacy96-driver/Makefile-libXNVCtrl
new file mode 100644
index 0000000000..15b03cc3ee
--- /dev/null
+++ b/system/nvidia-legacy96-driver/Makefile-libXNVCtrl
@@ -0,0 +1,32 @@
+# Copyright (c) 2008 NVIDIA, Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+RANLIB ?= ranlib
+
+libXNVCtrl.a : libXNVCtrl.a(NVCtrl.o)
+ $(RANLIB) $@
+
+NVCtrl.o : NVCtrl.h nv_control.h NVCtrlLib.h
+.INTERMEDIATE: NVCtrl.o
+
+clean ::
+ rm -f libXNVCtrl.a *.o
+.PHONY: clean