summaryrefslogtreecommitdiffstats
path: root/system/libtrash/libtrash.SlackBuild
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2022-02-14 12:31:00 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-16 09:11:57 +0700
commite81a892fe412ae323aad0a74c9c51161c6062ef0 (patch)
treec986e4b41c8f59b2c4ff427f7a5251702afd0230 /system/libtrash/libtrash.SlackBuild
parentb3f427721e92566943d110130d637ad0949c775d (diff)
downloadslackbuilds-e81a892fe412ae323aad0a74c9c51161c6062ef0.tar.gz
slackbuilds-e81a892fe412ae323aad0a74c9c51161c6062ef0.tar.xz
system/libtrash: Update for 3.7
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/libtrash/libtrash.SlackBuild')
-rw-r--r--system/libtrash/libtrash.SlackBuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/system/libtrash/libtrash.SlackBuild b/system/libtrash/libtrash.SlackBuild
index e781925754..e73344ab6b 100644
--- a/system/libtrash/libtrash.SlackBuild
+++ b/system/libtrash/libtrash.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/bash
+#!/bin/sh
# Slackware build script for libtrash
#
-# Copyright 2020 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2020-2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libtrash
-VERSION=${VERSION:-3.6}
+VERSION=${VERSION:-3.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,20 +79,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Inspired by the following Arch Linux AUR script:
-# https://aur.archlinux.org/packages/libtrash/
-sed -i -e s/ldconfig// ./src/Makefile
-sed -i -e s/python/python2/ ./src/Makefile
-
+./autogen.sh
+./configure --prefix=/usr --sysconfdir=/etc --disable-static --enable-shared
make
-install -d $PKG/usr/lib $PKG/etc
-make install INSTLIBDIR=$PKG/usr/lib SYSCONFFILE=$PKG/etc/libtrash.conf
+make DESTDIR=$PKG install
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING README.md TODO config.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS BUILD ChangeLog config.txt COPYING INSTALL NEWS README.md TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install