summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-04 05:37:23 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-09 10:14:17 +0700
commited9c9a4eec6507f3e8427e39f8b8a4f32e90e4f8 (patch)
treef0c945bfa039f542611748877a1ca68190cb4a5f /python
parent6dcb047ea5cc3a3016490b069cf00b566c23c357 (diff)
downloadslackbuilds-ed9c9a4eec6507f3e8427e39f8b8a4f32e90e4f8.tar.gz
slackbuilds-ed9c9a4eec6507f3e8427e39f8b8a4f32e90e4f8.tar.xz
python/python3-cheroot: Updated for version 10.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-cheroot/python3-cheroot.SlackBuild14
-rw-r--r--python/python3-cheroot/python3-cheroot.info6
2 files changed, 10 insertions, 10 deletions
diff --git a/python/python3-cheroot/python3-cheroot.SlackBuild b/python/python3-cheroot/python3-cheroot.SlackBuild
index 96666e00a6..37bbafe3f2 100644
--- a/python/python3-cheroot/python3-cheroot.SlackBuild
+++ b/python/python3-cheroot/python3-cheroot.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-cheroot
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-cheroot
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-9.0.0}
+VERSION=${VERSION:-10.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -62,6 +59,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -78,9 +78,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-cheroot/python3-cheroot.info b/python/python3-cheroot/python3-cheroot.info
index d3af1a6420..0d031ba05c 100644
--- a/python/python3-cheroot/python3-cheroot.info
+++ b/python/python3-cheroot/python3-cheroot.info
@@ -1,8 +1,8 @@
PRGNAM="python3-cheroot"
-VERSION="9.0.0"
+VERSION="10.0.0"
HOMEPAGE="https://cheroot.cherrypy.dev"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/c/cheroot/cheroot-9.0.0.tar.gz"
-MD5SUM="1617fdbaba7d6edbe5b0ff48f7563111"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/c/cheroot/cheroot-10.0.0.tar.gz"
+MD5SUM="be96fa052c54892240f916fbb06cc571"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-jaraco.functools python3-setuptools_scm_git_archive"