summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-12-17 10:23:29 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-22 08:00:20 +0700
commit986086867a1386ee059298e99fda52604c723ac1 (patch)
tree9adc865eac4adfbdfe5a7cf4e2ff73b7042312ae /python
parentcf8ba82597126ba6b11566dfb87e128ba6ad55b6 (diff)
downloadslackbuilds-986086867a1386ee059298e99fda52604c723ac1.tar.gz
slackbuilds-986086867a1386ee059298e99fda52604c723ac1.tar.xz
python/python3-hatch_vcs: Updated for version 0.4.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-hatch_vcs/python3-hatch_vcs.SlackBuild25
-rw-r--r--python/python3-hatch_vcs/python3-hatch_vcs.info6
2 files changed, 7 insertions, 24 deletions
diff --git a/python/python3-hatch_vcs/python3-hatch_vcs.SlackBuild b/python/python3-hatch_vcs/python3-hatch_vcs.SlackBuild
index 80893be36d..515e621734 100644
--- a/python/python3-hatch_vcs/python3-hatch_vcs.SlackBuild
+++ b/python/python3-hatch_vcs/python3-hatch_vcs.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-hatch_vcs
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-hatch_vcs
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-0.3.0}
+VERSION=${VERSION:-0.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,9 +59,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
#lower version requirement of setuptools-scm to get rid of warning
sed -i 's/6\.4\.0/6.3.2/' pyproject.toml
diff --git a/python/python3-hatch_vcs/python3-hatch_vcs.info b/python/python3-hatch_vcs/python3-hatch_vcs.info
index b34cbdb3b9..dffbccf682 100644
--- a/python/python3-hatch_vcs/python3-hatch_vcs.info
+++ b/python/python3-hatch_vcs/python3-hatch_vcs.info
@@ -1,8 +1,8 @@
PRGNAM="python3-hatch_vcs"
-VERSION="0.3.0"
+VERSION="0.4.0"
HOMEPAGE="https://github.com/ofek/hatch-vcs"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/h/hatch_vcs/hatch_vcs-0.3.0.tar.gz"
-MD5SUM="c2f2cbe6851b7b2969cb4aa24c4b9b2f"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/h/hatch_vcs/hatch_vcs-0.4.0.tar.gz"
+MD5SUM="d801fe7c3e5955307748f2790bbb3488"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-hatchling"