summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+github@gmail.com>2024-04-05 16:30:58 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-13 22:03:37 +0700
commit9369652256e3ed2e8266535b46862bde064d972f (patch)
tree811cb7334a9d2c05e673cbe55c0e3b0718cec6ec /python
parentfe6cd5009e7c6cfe79cb8a700db50663fce90736 (diff)
downloadslackbuilds-9369652256e3ed2e8266535b46862bde064d972f.tar.gz
slackbuilds-9369652256e3ed2e8266535b46862bde064d972f.tar.xz
python/python3-lazy_loader: Updated for version 0.4.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-lazy_loader/python3-lazy_loader.SlackBuild33
-rw-r--r--python/python3-lazy_loader/python3-lazy_loader.info8
2 files changed, 20 insertions, 21 deletions
diff --git a/python/python3-lazy_loader/python3-lazy_loader.SlackBuild b/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
index b323f3ec8b..785828adfa 100644
--- a/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
+++ b/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-lazy_loader
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-lazy_loader
-VERSION=${VERSION:-0.3}
+VERSION=${VERSION:-0.4}
SRCNAM=${SRCNAM:-lazy_loader}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,7 +62,20 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# For no setup.py (requires wheel & python3-installer as dependencies)
+# Use separate setuptools
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+
+# Let setuptools-scm know what the version is without requiring pypi source
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl
diff --git a/python/python3-lazy_loader/python3-lazy_loader.info b/python/python3-lazy_loader/python3-lazy_loader.info
index 7d894dbf41..d2b683c828 100644
--- a/python/python3-lazy_loader/python3-lazy_loader.info
+++ b/python/python3-lazy_loader/python3-lazy_loader.info
@@ -1,10 +1,10 @@
PRGNAM="python3-lazy_loader"
-VERSION="0.3"
+VERSION="0.4"
HOMEPAGE="https://scientific-python.org/specs/spec-0001/"
-DOWNLOAD="https://github.com/scientific-python/lazy_loader/archive/refs/tags/v0.3/lazy_loader-0.3.tar.gz"
-MD5SUM="6b93a98e974103e78d026d9b93b15236"
+DOWNLOAD="https://github.com/scientific-python/lazy_loader/archive/refs/tags/v0.4/lazy_loader-0.4.tar.gz"
+MD5SUM="1484ab53ffad77fe42803095686c1e25"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-build"
+REQUIRES="python3-build python3-setuptools-opt"
MAINTAINER="Jeremy Hansen"
EMAIL="jebrhansen+SBo@gmail.com"