summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+SBo@gmail.com>2024-04-06 07:14:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-13 22:02:12 +0700
commit9159b81f4886ce918a63a757dc469e4d99f01df0 (patch)
treed72e07e1eca7cf45c5906a31560553799595ab4b /python
parent36f5dea92793b863d79d805b54a3a3cea3063241 (diff)
downloadslackbuilds-9159b81f4886ce918a63a757dc469e4d99f01df0.tar.gz
slackbuilds-9159b81f4886ce918a63a757dc469e4d99f01df0.tar.xz
python/python3-msal: Added (Python3 version of python-msal).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-msal/README8
-rw-r--r--python/python3-msal/python3-msal.SlackBuild80
-rw-r--r--python/python3-msal/python3-msal.info10
-rw-r--r--python/python3-msal/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/python3-msal/README b/python/python3-msal/README
new file mode 100644
index 0000000000..0bdc60387e
--- /dev/null
+++ b/python/python3-msal/README
@@ -0,0 +1,8 @@
+python3-msal (Microsoft Authentication Library (MSAL) for Python)
+
+The Microsoft Authentication Library for Python enables applications
+to integrate with the Microsoft identity platform. It allows you
+to sign in users or apps with Microsoft identities (Azure AD,
+Microsoft Accounts and Azure AD B2C accounts) and obtain tokens
+to call Microsoft APIs such as Microsoft Graph or your own APIs
+registered with the Microsoft identity platform.
diff --git a/python/python3-msal/python3-msal.SlackBuild b/python/python3-msal/python3-msal.SlackBuild
new file mode 100644
index 0000000000..ee4b7a2a5a
--- /dev/null
+++ b/python/python3-msal/python3-msal.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/bash
+
+# Slackware build script for python3-msal
+
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-msal
+VERSION=${VERSION:-1.28.0}
+SRCNAM=${SRCNAM:-microsoft-authentication-library-for-python}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-msal/python3-msal.info b/python/python3-msal/python3-msal.info
new file mode 100644
index 0000000000..c6e3f117e1
--- /dev/null
+++ b/python/python3-msal/python3-msal.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-msal"
+VERSION="1.28.0"
+HOMEPAGE="https://msal-python.readthedocs.io/"
+DOWNLOAD="https://github.com/AzureAD/microsoft-authentication-library-for-python/archive/refs/tags/1.28.0/microsoft-authentication-library-for-python-1.28.0.tar.gz"
+MD5SUM="7951a366dcae3902e9421bad429b9c98"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="cryptography python3-pyjwt"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python3-msal/slack-desc b/python/python3-msal/slack-desc
new file mode 100644
index 0000000000..afc902d51e
--- /dev/null
+++ b/python/python3-msal/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-msal: python3-msal (Microsoft Authentication Library (MSAL) for Python)
+python3-msal:
+python3-msal: The Microsoft Authentication Library for Python enables applications
+python3-msal: to integrate with the Microsoft identity platform. It allows you
+python3-msal: to sign in users or apps with Microsoft identities (Azure AD,
+python3-msal: Microsoft Accounts and Azure AD B2C accounts) and obtain tokens
+python3-msal: to call Microsoft APIs such as Microsoft Graph or your own APIs
+python3-msal: registered with the Microsoft identity platform.
+python3-msal:
+python3-msal: HOMEPAGE: https://msal-python.readthedocs.io/
+python3-msal: