summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+github@gmail.com>2024-04-08 17:13:22 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-13 22:03:39 +0700
commit866f542c863566ce2d089c5141c73626913dad50 (patch)
tree2f1a5dc7bd9d9b760a648bac5fa454d456420ac0 /python
parentb01704b0c6bc826e7a973b1238695c8944d65680 (diff)
downloadslackbuilds-866f542c863566ce2d089c5141c73626913dad50.tar.gz
slackbuilds-866f542c863566ce2d089c5141c73626913dad50.tar.xz
python/python3-joblib: Updated for version 1.4.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-joblib/python3-joblib.SlackBuild11
-rw-r--r--python/python3-joblib/python3-joblib.info6
2 files changed, 12 insertions, 5 deletions
diff --git a/python/python3-joblib/python3-joblib.SlackBuild b/python/python3-joblib/python3-joblib.SlackBuild
index f521684d5c..0d9f19d1c3 100644
--- a/python/python3-joblib/python3-joblib.SlackBuild
+++ b/python/python3-joblib/python3-joblib.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2019-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
-# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
+# Copyright 2023-2024 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-joblib
SRCNAM=joblib
-VERSION=${VERSION:-1.3.2}
+VERSION=${VERSION:-1.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,6 +70,13 @@ find -L . \
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
export PYTHONPATH=/opt/python$PYVER/site-packages/
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir "$PKG" dist/*.whl
diff --git a/python/python3-joblib/python3-joblib.info b/python/python3-joblib/python3-joblib.info
index 2ed6ff753f..70c056d5cc 100644
--- a/python/python3-joblib/python3-joblib.info
+++ b/python/python3-joblib/python3-joblib.info
@@ -1,8 +1,8 @@
PRGNAM="python3-joblib"
-VERSION="1.3.2"
+VERSION="1.4.0"
HOMEPAGE="https://joblib.readthedocs.io/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/j/joblib/joblib-1.3.2.tar.gz"
-MD5SUM="d3b410f1d0681e5ad48a83b0d692e0fd"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/j/joblib/joblib-1.4.0.tar.gz"
+MD5SUM="496285737120962e2aea01ac21c8bdca"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-setuptools-opt"