summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-04-23 19:52:22 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-29 17:20:29 +0700
commit3bf34316e343050c1eda84e72d66c11a71a99484 (patch)
tree640e105aaaadfa29eed3507927ce7bd24e0c565a /python
parentf4e826bba1778c885cd0d033a162dceb04230a2d (diff)
downloadslackbuilds-3bf34316e343050c1eda84e72d66c11a71a99484.tar.gz
slackbuilds-3bf34316e343050c1eda84e72d66c11a71a99484.tar.xz
python/iniconfig: Remove Python 2 support
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/iniconfig/iniconfig.SlackBuild6
-rw-r--r--python/iniconfig/iniconfig.info2
2 files changed, 2 insertions, 6 deletions
diff --git a/python/iniconfig/iniconfig.SlackBuild b/python/iniconfig/iniconfig.SlackBuild
index bbeb09bd86..32d6f0617a 100644
--- a/python/iniconfig/iniconfig.SlackBuild
+++ b/python/iniconfig/iniconfig.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=iniconfig
VERSION=${VERSION:-1.1.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +76,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/iniconfig/iniconfig.info b/python/iniconfig/iniconfig.info
index 51d328dd6f..050a856c42 100644
--- a/python/iniconfig/iniconfig.info
+++ b/python/iniconfig/iniconfig.info
@@ -1,7 +1,7 @@
PRGNAM="iniconfig"
VERSION="1.1.1"
HOMEPAGE="https://github.com/RonnyPfannschmidt/iniconfig"
-DOWNLOAD="https://files.pythonhosted.org/packages/23/a2/97899f6bd0e873fed3a7e67ae8d3a08b21799430fb4da15cfedf10d6e2c2/iniconfig-1.1.1.tar.gz"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/i/iniconfig/iniconfig-1.1.1.tar.gz"
MD5SUM="0b7f3be87481211c183eae095bcea6f1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""