summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-12-31 17:44:13 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-06 08:08:43 +0700
commit261aee740d936d5b9a08139f72ec430331c7de19 (patch)
tree130cee1ce30e07ba3b6d7079887a4371741c0581 /python
parent215f09315abd0dbb42b5819e5ff998bba86c3483 (diff)
downloadslackbuilds-261aee740d936d5b9a08139f72ec430331c7de19.tar.gz
slackbuilds-261aee740d936d5b9a08139f72ec430331c7de19.tar.xz
python/sphinxcontrib-htmlhelp: Updated for version 2.0.4, new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild36
-rw-r--r--python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info12
2 files changed, 18 insertions, 30 deletions
diff --git a/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild b/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild
index 56bf2b900f..f53ef2cead 100644
--- a/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild
+++ b/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for sphinxcontrib-htmlhelp
+# Copyright 2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2019-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240101 46and2: Updated version, new maintainer.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sphinxcontrib-htmlhelp
-VERSION=${VERSION:-2.0.0}
+SRCNAM=sphinxcontrib_htmlhelp
+VERSION=${VERSION:-2.0.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,36 +51,23 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info b/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info
index 414ef972f0..8945846d24 100644
--- a/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info
+++ b/python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp.info
@@ -1,10 +1,10 @@
PRGNAM="sphinxcontrib-htmlhelp"
-VERSION="2.0.0"
+VERSION="2.0.4"
HOMEPAGE="https://github.com/sphinx-doc/sphinxcontrib-htmlhelp"
-DOWNLOAD="https://files.pythonhosted.org/packages/eb/85/93464ac9bd43d248e7c74573d58a791d48c475230bcf000df2b2700b9027/sphinxcontrib-htmlhelp-2.0.0.tar.gz"
-MD5SUM="70765b55395a3c20233631802902c840"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/s/sphinxcontrib-htmlhelp/sphinxcontrib_htmlhelp-2.0.4.tar.gz"
+MD5SUM="cbc0df02c4716f995a0410d455837b3b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
+REQUIRES="python3-build"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"