summaryrefslogtreecommitdiffstats
path: root/python/python3-mpi4py
diff options
context:
space:
mode:
author William PC <w_calandrini[at]hotmail[dot]com>2022-12-15 19:48:10 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-17 09:13:58 +0700
commit2158e832e84dd168e54debed5e1db941067e94f5 (patch)
tree94cf053ff05c3a5f4915822fa6eee27ecac17f33 /python/python3-mpi4py
parent2dd111794d18fcfe10d289176cd3cc4a524d8f49 (diff)
downloadslackbuilds-2158e832e84dd168e54debed5e1db941067e94f5.tar.gz
slackbuilds-2158e832e84dd168e54debed5e1db941067e94f5.tar.xz
python/python3-mpi4py: Added (Message Passing Interface bindings)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-mpi4py')
-rw-r--r--python/python3-mpi4py/README4
-rw-r--r--python/python3-mpi4py/python3-mpi4py.SlackBuild113
-rw-r--r--python/python3-mpi4py/python3-mpi4py.info10
-rw-r--r--python/python3-mpi4py/slack-desc19
4 files changed, 146 insertions, 0 deletions
diff --git a/python/python3-mpi4py/README b/python/python3-mpi4py/README
new file mode 100644
index 0000000000..6475a11137
--- /dev/null
+++ b/python/python3-mpi4py/README
@@ -0,0 +1,4 @@
+ This package provides Python bindings for the Message Passing
+Interface (MPI) standard. It is implemented on top of the MPI
+specification and exposes an API which grounds on the standard
+MPI-2 C++ bindings.
diff --git a/python/python3-mpi4py/python3-mpi4py.SlackBuild b/python/python3-mpi4py/python3-mpi4py.SlackBuild
new file mode 100644
index 0000000000..deb0a59e67
--- /dev/null
+++ b/python/python3-mpi4py/python3-mpi4py.SlackBuild
@@ -0,0 +1,113 @@
+#!/bin/bash
+
+# Slackware build script for mpi4py
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-mpi4py
+VERSION=${VERSION:-3.1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=$(echo $PRGNAM | cut -d- -f2)
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+# this is failling even with mpich
+rm test/test_util_dtlib.py
+
+python3 setup.py build
+# dont use with openmpi
+if [ $(which mpichversion 2> /dev/null ) ]; then
+ python3 test/runtests.py
+fi
+python3 setup.py install --root=$PKG
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ {CHANGES,DESCRIPTION,LICENSE}.rst docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-mpi4py/python3-mpi4py.info b/python/python3-mpi4py/python3-mpi4py.info
new file mode 100644
index 0000000000..5342fbeada
--- /dev/null
+++ b/python/python3-mpi4py/python3-mpi4py.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-mpi4py"
+VERSION="3.1.4"
+HOMEPAGE="https://pypi.org/project/mpi4py"
+DOWNLOAD="https://files.pythonhosted.org/packages/bc/f2/749af7fd0e7703ddca6cea525ab40f26c3ca6cbe6c23658441c6f9705860/mpi4py-3.1.4.tar.gz"
+MD5SUM="09e20c0128207303a3d0462eb6b0c0e3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="mpich"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/python/python3-mpi4py/slack-desc b/python/python3-mpi4py/slack-desc
new file mode 100644
index 0000000000..93470b9b6b
--- /dev/null
+++ b/python/python3-mpi4py/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-mpi4py: python3-mpi4py (Python bindings for Message Passing Interface (MPI))
+python3-mpi4py:
+python3-mpi4py:
+python3-mpi4py: This package provides Python bindings for the Message Passing
+python3-mpi4py: Interface (MPI) standard. It is implemented on top of the MPI
+python3-mpi4py: specification and exposes an API which grounds on the standard
+python3-mpi4py: MPI-2 C++ bindings.
+python3-mpi4py:
+python3-mpi4py:
+python3-mpi4py:
+python3-mpi4py: