summaryrefslogtreecommitdiffstats
path: root/python/python3-glances/python3-glances.SlackBuild
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-01-22 09:37:25 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-28 08:22:49 +0700
commitcd6e48e3c443af2bf0620002e7f5b6c24bffb1ae (patch)
tree8442f90d81041d83b0f85a29e14e71ca534ebdc0 /python/python3-glances/python3-glances.SlackBuild
parent3242ce9e63f15f127839dd1e339060496a5fec03 (diff)
downloadslackbuilds-cd6e48e3c443af2bf0620002e7f5b6c24bffb1ae.tar.gz
slackbuilds-cd6e48e3c443af2bf0620002e7f5b6c24bffb1ae.tar.xz
python/python3-glances: Updated for version 3.3.1.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-glances/python3-glances.SlackBuild')
-rw-r--r--python/python3-glances/python3-glances.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/python/python3-glances/python3-glances.SlackBuild b/python/python3-glances/python3-glances.SlackBuild
index 07f59d7835..d876f41178 100644
--- a/python/python3-glances/python3-glances.SlackBuild
+++ b/python/python3-glances/python3-glances.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-glances
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-glances
SRCNAM=$(echo $PRGNAM | sed "s/python3-//" |sed 's/.*/\u&/')
-VERSION=${VERSION:-3.3.0.4}
+VERSION=${VERSION:-3.3.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +73,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
#change location to install man pages
sed -i 's|share/man|man|g' setup.py