summaryrefslogtreecommitdiffstats
path: root/python/python3-fonttools
diff options
context:
space:
mode:
author Vijay Marcel <vijaymarcel@outlook.com>2024-02-26 07:59:23 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-28 12:22:40 +0700
commit90d9d2bbd3fe66b54fbd670af84487f7faebb277 (patch)
tree594057737c4eb19e64c1e770fec4f923d789bdd2 /python/python3-fonttools
parent1694337de79e237201d89acee86366764e38b1cd (diff)
downloadslackbuilds-90d9d2bbd3fe66b54fbd670af84487f7faebb277.tar.gz
slackbuilds-90d9d2bbd3fe66b54fbd670af84487f7faebb277.tar.xz
python/python3-fonttools: Updated for version 4.49.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-fonttools')
-rw-r--r--python/python3-fonttools/README13
-rw-r--r--python/python3-fonttools/python3-fonttools.SlackBuild14
-rw-r--r--python/python3-fonttools/python3-fonttools.info8
3 files changed, 19 insertions, 16 deletions
diff --git a/python/python3-fonttools/README b/python/python3-fonttools/README
index 54c96a23e4..ce6ddefb1b 100644
--- a/python/python3-fonttools/README
+++ b/python/python3-fonttools/README
@@ -2,11 +2,14 @@ python-fonttools - A library to manipulate font files from Python.
Optional dependencies:
-lxml – faster backend for XML files reading/writing
+python3-reportlab – to drawing glyphs as PNG images
-python3-matplotlib – for visualizing
-DesignSpaceDocument and resulting VariationModel
+python3-sympy – for symbolic font statistics analysis
-python-reportlab – to drawing glyphs as PNG images
-python3-sympy – for symbolic font statistics analysis
+Note:
+Install pytz, Sphinx, sphinx-rtd-theme, snowballstemmer,
+imagesize,msgpack-python, html5lib first and then go for
+other dependencies.If you encounter an error about syntax
+error in python then check if the slackbuild builds for python2,
+disable it and then try to install.
diff --git a/python/python3-fonttools/python3-fonttools.SlackBuild b/python/python3-fonttools/python3-fonttools.SlackBuild
index c5702f50fa..9a1842db97 100644
--- a/python/python3-fonttools/python3-fonttools.SlackBuild
+++ b/python/python3-fonttools/python3-fonttools.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for python3-fonttools
# Copyright 2017-2019,2022 Andrew Clemons, Wellington New Zealand
-# Copyright 2023 Vijay Marcel
+# Copyright 2023-2024 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-fonttools
SRCNAM=fonttools
-VERSION=${VERSION:-4.42.1}
+VERSION=${VERSION:-4.49.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -56,7 +56,7 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-march=i686 -mtune=i686 -pipe -O2 -fPIC"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-march=x86-64 -mtune=generic -pipe -O2 -fPIC"
+ SLKCFLAGS="-march=x86-64 -mtune=generic -pipe -O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
@@ -64,6 +64,7 @@ else
fi
set -e
+trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ERR
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -78,16 +79,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --remove-section=.comment --remove-section=.note 2> /dev/null || true
mv -v $PKG/usr/share/man $PKG/usr
rm -rvf $PKG/usr/share
cd Doc
-make singlehtml
make man
mv -v $TMP/$SRCNAM-$VERSION/Doc/build/man/fonttools.1 $PKG/usr/man/man1/
cd ..
@@ -97,7 +98,6 @@ for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; r
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CONTRIBUTING.md LICENSE.external LICENSE README.rst CODE_OF_CONDUCT.md NEWS.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $TMP/$SRCNAM-$VERSION/Doc/build/singlehtml $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
diff --git a/python/python3-fonttools/python3-fonttools.info b/python/python3-fonttools/python3-fonttools.info
index b985119e87..5358737260 100644
--- a/python/python3-fonttools/python3-fonttools.info
+++ b/python/python3-fonttools/python3-fonttools.info
@@ -1,10 +1,10 @@
PRGNAM="python3-fonttools"
-VERSION="4.42.1"
+VERSION="4.49.0"
HOMEPAGE="https://github.com/fonttools/fonttools"
-DOWNLOAD="https://github.com/fonttools/fonttools/archive/4.42.1/fonttools-4.42.1.tar.gz"
-MD5SUM="c83eed649a5d20e78beb3d9d5b61371c"
+DOWNLOAD="https://github.com/fonttools/fonttools/archive/4.49.0/fonttools-4.49.0.tar.gz"
+MD5SUM="345cb539ea4ccd96df61699752a63ad6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python-unicodedata2 munkres python3-scipy zopfli python3-fs python3-uharfbuzz freetype-py"
+REQUIRES="python-unicodedata2 munkres python3-scipy python3-zopfli python3-fs python3-uharfbuzz freetype-py python3-matplotlib python3-lxml python3-lz4"
MAINTAINER="Vijay Marcel"
EMAIL="vijaymarcel@outlook.com"