summaryrefslogtreecommitdiffstats
path: root/python/python3-fasteners/python3-fasteners.SlackBuild
diff options
context:
space:
mode:
author Pouria Rezaei <Pouria.rz@outlook.com>2022-01-17 18:50:07 +0330
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-01-18 08:14:21 +0700
commite3b4641a3d9e466fdbefdfcad18f88fcfca5b389 (patch)
treeaf338a84a6585ff564765d64c92930ffd6f08654 /python/python3-fasteners/python3-fasteners.SlackBuild
parent28a6ada9ebadab27a9c2aa1da2a528705d08794a (diff)
downloadslackbuilds-e3b4641a3d9e466fdbefdfcad18f88fcfca5b389.tar.gz
slackbuilds-e3b4641a3d9e466fdbefdfcad18f88fcfca5b389.tar.xz
python/python3-fasteners: Updated for version 0.17.2.
New creepy packaging method with setup.cfg; I personally don't like it. Signed-off-by: Pouria Rezaei <Pouria.rz@outlook.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-fasteners/python3-fasteners.SlackBuild')
-rw-r--r--python/python3-fasteners/python3-fasteners.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/python3-fasteners/python3-fasteners.SlackBuild b/python/python3-fasteners/python3-fasteners.SlackBuild
index 1c3b30a191..4bcf843685 100644
--- a/python/python3-fasteners/python3-fasteners.SlackBuild
+++ b/python/python3-fasteners/python3-fasteners.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-fasteners
-# Copyright 2019-2021 Pouria Rezaei <Pouria.rz@outlook.com>
+# Copyright 2019-2022 Pouria Rezaei <Pouria.rz@outlook.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-fasteners
-VERSION=${VERSION:-0.16.3}
+VERSION=${VERSION:-0.17.2}
SRCNAM=fasteners
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -72,10 +72,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -c 'from setuptools import setup; setup()' install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog LICENSE MANIFEST.in README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG LICENSE MANIFEST.in README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install