summaryrefslogtreecommitdiffstats
path: root/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+github@gmail.com>2023-12-21 15:48:30 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-22 07:31:22 +0700
commit5bdd4ad63161f1241e58c689ff613ea1a74f3c57 (patch)
tree98dc4fce1961e148d2e9ebcbeb04c20ce13f67ad /python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
parente6594347a59f17c6fc7665634825f7636a71c2a0 (diff)
downloadslackbuilds-5bdd4ad63161f1241e58c689ff613ea1a74f3c57.tar.gz
slackbuilds-5bdd4ad63161f1241e58c689ff613ea1a74f3c57.tar.xz
python/python3-dogpile.cache: Version bump to 1.3.0
Also thanks to fourtysixandtwo for catching the missing typing-extensions dep Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild')
-rw-r--r--python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild23
1 files changed, 6 insertions, 17 deletions
diff --git a/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild b/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
index 9698f6abb3..c986ded39b 100644
--- a/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
+++ b/python/python3-dogpile.cache/python3-dogpile.cache.SlackBuild
@@ -24,10 +24,10 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-dogpile.cache
-VERSION=${VERSION:-1.2.2}
+VERSION=${VERSION:-1.3.0}
SRCNAM=${SRCNAM:-dogpile.cache}
SRCVER=${SRCVER:-rel_$(echo $VERSION | tr . _)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -77,7 +63,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true