summaryrefslogtreecommitdiffstats
path: root/python/python3-APScheduler/python3-APScheduler.SlackBuild
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2023-04-10 08:17:12 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-15 07:15:35 +0700
commit074e47259d4858ab62f3e65bcc22d95ee4223856 (patch)
tree08a48c1e9441d236c5ae990e5f476c94c07ffc91 /python/python3-APScheduler/python3-APScheduler.SlackBuild
parent81080408c52d601f0099717c649101e379a959d5 (diff)
downloadslackbuilds-074e47259d4858ab62f3e65bcc22d95ee4223856.tar.gz
slackbuilds-074e47259d4858ab62f3e65bcc22d95ee4223856.tar.xz
python/python3-APScheduler: Updated for version 3.10.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-APScheduler/python3-APScheduler.SlackBuild')
-rw-r--r--python/python3-APScheduler/python3-APScheduler.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/python/python3-APScheduler/python3-APScheduler.SlackBuild b/python/python3-APScheduler/python3-APScheduler.SlackBuild
index ccacefc662..a7f3291d76 100644
--- a/python/python3-APScheduler/python3-APScheduler.SlackBuild
+++ b/python/python3-APScheduler/python3-APScheduler.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-APScheduler
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-APScheduler
SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-3.9.1.post1}
+VERSION=${VERSION:-3.10.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +73,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG