summaryrefslogtreecommitdiffstats
path: root/python/python-wrapt
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:46 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:52 +0700
commit6f64e7cbecf2e55dad4c8a5ffd93e1b040e896cb (patch)
tree76aa96b103684a6529336475e7ff163484621092 /python/python-wrapt
parent496b88fbfae28b0d7981fafe08a15500d5931414 (diff)
downloadslackbuilds-6f64e7cbecf2e55dad4c8a5ffd93e1b040e896cb.tar.gz
slackbuilds-6f64e7cbecf2e55dad4c8a5ffd93e1b040e896cb.tar.xz
python/python-wrapt: Renamed python2-wrapt.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-wrapt')
-rw-r--r--python/python-wrapt/README5
-rw-r--r--python/python-wrapt/python-wrapt.SlackBuild86
-rw-r--r--python/python-wrapt/python-wrapt.info10
-rw-r--r--python/python-wrapt/slack-desc19
4 files changed, 0 insertions, 120 deletions
diff --git a/python/python-wrapt/README b/python/python-wrapt/README
deleted file mode 100644
index 84fd2ce36f..0000000000
--- a/python/python-wrapt/README
+++ /dev/null
@@ -1,5 +0,0 @@
-A Python module for decorators, wrappers and monkey patching.
-
-The aim of the wrapt module is to provide a transparent object proxy
-for Python, which can be used as the basis for the construction of
-function wrappers and decorator functions.
diff --git a/python/python-wrapt/python-wrapt.SlackBuild b/python/python-wrapt/python-wrapt.SlackBuild
deleted file mode 100644
index 2a3b8e0c2d..0000000000
--- a/python/python-wrapt/python-wrapt.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-wrapt
-
-# Copyright 2015-2019 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-wrapt
-SRCNAM=$(echo $PRGNAM | cut -c8-12)
-VERSION=${VERSION:-1.11.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-wrapt/python-wrapt.info b/python/python-wrapt/python-wrapt.info
deleted file mode 100644
index ee20a397fb..0000000000
--- a/python/python-wrapt/python-wrapt.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-wrapt"
-VERSION="1.11.1"
-HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
-DOWNLOAD="https://files.pythonhosted.org/packages/67/b2/0f71ca90b0ade7fad27e3d20327c996c6252a2ffe88f50a95bba7434eda9/wrapt-1.11.1.tar.gz"
-MD5SUM="9f21acd7c0a57bf3057715c4665db3c7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-wrapt/slack-desc b/python/python-wrapt/slack-desc
deleted file mode 100644
index a89ef17fbb..0000000000
--- a/python/python-wrapt/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-wrapt: python-wrapt (A Python module for decorators)
-python-wrapt:
-python-wrapt: A Python module for decorators, wrappers and monkey patching.
-python-wrapt: The aim of the wrapt module is to provide a transparent object proxy
-python-wrapt: for Python, which can be used as the basis for the construction of
-python-wrapt: function wrappers and decorator functions.
-python-wrapt:
-python-wrapt: Homepage: https://github.com/GrahamDumpleton/wrapt
-python-wrapt:
-python-wrapt:
-python-wrapt: