summaryrefslogtreecommitdiffstats
path: root/python/python-wand
diff options
context:
space:
mode:
author Giancarlo Dessì <slack@giand.it>2023-06-02 20:36:52 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-03 10:38:22 +0700
commit71c7a9820e1c30b002f615654f6cc55f885b64c7 (patch)
tree87d0be3eb77b44ef8525a54c40b135eeee9c95e0 /python/python-wand
parent7aec2fc9868deb4ecc9128428eb8a1056c4d3899 (diff)
downloadslackbuilds-71c7a9820e1c30b002f615654f6cc55f885b64c7.tar.gz
slackbuilds-71c7a9820e1c30b002f615654f6cc55f885b64c7.tar.xz
python/python-wand: Added (ImageMagick binding for Python)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-wand')
-rw-r--r--python/python-wand/README3
-rw-r--r--python/python-wand/python-wand.SlackBuild95
-rw-r--r--python/python-wand/python-wand.info10
-rw-r--r--python/python-wand/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/python/python-wand/README b/python/python-wand/README
new file mode 100644
index 0000000000..47734410a8
--- /dev/null
+++ b/python/python-wand/README
@@ -0,0 +1,3 @@
+Wand is a ctypes-based simple ImageMagick binding for Python,
+supporting 2.7, 3.3+, and PyPy.
+All functionalities of MagickWand API are implemented in Wand.
diff --git a/python/python-wand/python-wand.SlackBuild b/python/python-wand/python-wand.SlackBuild
new file mode 100644
index 0000000000..9c0d55fb08
--- /dev/null
+++ b/python/python-wand/python-wand.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/bash
+
+# Slackware build script for python-wand
+
+# Copyright 2023 Giancarlo Dessì, Cagliari, IT
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python-wand
+SRCNAM=Wand
+VERSION=${VERSION:-0.6.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python-wand/python-wand.info b/python/python-wand/python-wand.info
new file mode 100644
index 0000000000..6fbd1201cb
--- /dev/null
+++ b/python/python-wand/python-wand.info
@@ -0,0 +1,10 @@
+PRGNAM="python-wand"
+VERSION="0.6.11"
+HOMEPAGE="https://docs.wand-py.org"
+DOWNLOAD="https://files.pythonhosted.org/packages/53/64/418742debfecf0f79ab0b23cae508846f554fa308f4e4c8617ed84fa5a29/Wand-0.6.11.tar.gz"
+MD5SUM="1402ebe0398c8636c61e9a1a0b481e85"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Giancarlo Dessì"
+EMAIL="slack@giand.it"
diff --git a/python/python-wand/slack-desc b/python/python-wand/slack-desc
new file mode 100644
index 0000000000..e4804e9029
--- /dev/null
+++ b/python/python-wand/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-wand: python-wand (ImageMagick binding for Python)
+python-wand:
+python-wand: Wand is a ctypes-based simple ImageMagick binding for Python.
+python-wand: It implements all functionalities of MagickWand API.
+python-wand:
+python-wand:
+python-wand:
+python-wand:
+python-wand: Home page: https://docs.wand-py.org
+python-wand:
+python-wand: